package/pinentry: bump to version 1.1.1
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 29 Jan 2021 17:44:54 +0000 (18:44 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 30 Jan 2021 10:38:39 +0000 (11:38 +0100)
- add efl optional dependency which is available since
  http://git.gnupg.org/cgi-bin/gitweb.cgi?p=pinentry.git;a=commit;h=948105b7a34ec9a9e5479d376b7c86bafee50a01
- Update indentation in hash file (two spaces)

http://git.gnupg.org/cgi-bin/gitweb.cgi?p=pinentry.git;a=blob;f=NEWS;h=c8b5195ace7bb3ffb1420ae479ac39d65b0fa17c

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pinentry/Config.in
package/pinentry/pinentry.hash
package/pinentry/pinentry.mk

index 586ffea2959292accc27adef89ccc95c99754d54..684e4eed4a8e7e25f9c6152ae4d238948bf3ff4c 100644 (file)
@@ -15,6 +15,17 @@ menuconfig BR2_PACKAGE_PINENTRY
 
 if BR2_PACKAGE_PINENTRY
 
+config BR2_PACKAGE_PINENTRY_EFL
+       bool "pinentry-efl"
+       depends on BR2_PACKAGE_EFL
+       depends on BR2_PACKAGE_XORG7
+       select BR2_PACKAGE_EFL_X_XLIB
+       help
+         The pinentry-efl tool
+
+comment "pinentry-efl needs efl and X"
+       depends on !BR2_PACKAGE_EFL || !BR2_PACKAGE_XORG7
+
 config BR2_PACKAGE_PINENTRY_FLTK
        bool "pinentry-fltk"
        depends on BR2_USE_MMU # fltk
index c9610d6eb13a76ee7744366c77b3bc09e576618d..e5f3d906521417afe5ae4e4f0654ba5df000e81b 100644 (file)
@@ -1,5 +1,5 @@
 # From https://www.gnupg.org/download/integrity_check.html
-sha1  693bdf9f48dfb3e040d92f50b1bb464e268b9fb0  pinentry-1.1.0.tar.bz2
+sha1  b8b88cab4fd844e3616d55aeba8f084f2b98fb0f  pinentry-1.1.1.tar.bz2
 # Locally computed
-sha256 68076686fa724a290ea49cdf0d1c0c1500907d1b759a3bcbfbec0293e8f56570  pinentry-1.1.0.tar.bz2
-sha256 67f82e045cf7acfef853ea0f426575a8359161a0a325e19f02b529a87c4b6c34  COPYING
+sha256  cd12a064013ed18e2ee8475e669b9f58db1b225a0144debdb85a68cecddba57f  pinentry-1.1.1.tar.bz2
+sha256  67f82e045cf7acfef853ea0f426575a8359161a0a325e19f02b529a87c4b6c34  COPYING
index e7bd31d40e73357e7eaa88266f93e80c209c0291..8ebd35cfab3f8c2078daa3dad7765065d90623b8 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-PINENTRY_VERSION = 1.1.0
+PINENTRY_VERSION = 1.1.1
 PINENTRY_SOURCE = pinentry-$(PINENTRY_VERSION).tar.bz2
 PINENTRY_SITE = https://www.gnupg.org/ftp/gcrypt/pinentry
 PINENTRY_LICENSE = GPL-2.0+
@@ -29,6 +29,14 @@ else
 PINENTRY_CONF_OPTS += --disable-libsecret
 endif
 
+# pinentry-efl backend
+ifeq ($(BR2_PACKAGE_PINENTRY_EFL),y)
+PINENTRY_CONF_OPTS += --enable-pinentry-efl
+PINENTRY_DEPENDENCIES += efl
+else
+PINENTRY_CONF_OPTS += --disable-pinentry-efl
+endif
+
 # pinentry-fltk backend
 ifeq ($(BR2_PACKAGE_PINENTRY_FLTK),y)
 PINENTRY_CONF_ENV += ac_cv_path_FLTK_CONFIG=$(STAGING_DIR)/usr/bin/fltk-config