ola: disable -Werror
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 21 Nov 2013 22:18:25 +0000 (23:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 22 Nov 2013 11:12:10 +0000 (12:12 +0100)
By default, the ola build uses -Werror, so let's pass
--disable-fatal-warnings to remove this and avoid build failures
caused by warnings.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ola/ola.mk

index 835ca4e50443b1ea356b76108f1e56afe62581b7..bc7de244221eb0ddc82b5c82af3d6298e762e238 100644 (file)
@@ -19,7 +19,8 @@ OLA_CONF_OPT = \
        --disable-tcmalloc \
        --disable-unittests \
        --disable-root-check \
-       --disable-java-libs
+       --disable-java-libs \
+       --disable-fatal-warnings
 
 # sets where to find python libs built for target and required by ola
 OLA_CONF_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages