bzip2: fix passing of TARGET_MAKE_ENV to make
authorLuca Ceresoli <luca@lucaceresoli.net>
Fri, 13 Oct 2017 10:43:24 +0000 (12:43 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 15 Oct 2017 14:00:25 +0000 (16:00 +0200)
TARGET_MAKE_ENV is not passed to make because it is on a different
line without a backslash.

Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/bzip2/bzip2.mk

index 62571ed5a3a6265f856d83116f75076bc33885ba..e43533072b2d77a865e132fc47913a833af77d6d 100644 (file)
@@ -12,13 +12,13 @@ BZIP2_LICENSE_FILES = LICENSE
 
 ifeq ($(BR2_STATIC_LIBS),)
 define BZIP2_BUILD_SHARED_CMDS
-       $(TARGET_MAKE_ENV)
+       $(TARGET_MAKE_ENV) \
                $(MAKE) -C $(@D) -f Makefile-libbz2_so $(TARGET_CONFIGURE_OPTS)
 endef
 endif
 
 define BZIP2_BUILD_CMDS
-       $(TARGET_MAKE_ENV)
+       $(TARGET_MAKE_ENV) \
                $(MAKE) -C $(@D) libbz2.a bzip2 bzip2recover $(TARGET_CONFIGURE_OPTS)
        $(BZIP2_BUILD_SHARED_CMDS)
 endef