package/libinput: bump version to 0.19.0, add locale dependency
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 15 Jul 2015 18:11:43 +0000 (20:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 18 Jul 2015 10:24:17 +0000 (12:24 +0200)
Since 2015-04-22 libinput needs locale support:
http://cgit.freedesktop.org/wayland/libinput/commit/src/libinput-util.c?id=5c671e0375cc03032fcac26efe4a7835a74c8bfc

This patch adds the needed dependency also to
weston and xdriver_xf86-input-libinput.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libinput/Config.in
package/libinput/libinput.hash
package/libinput/libinput.mk
package/weston/Config.in
package/x11r7/xdriver_xf86-input-libinput/Config.in

index 14e4e70f96a38357e834e11646e06f3acaf91e60..f7793df84fc06ed144680fd97b04cc21c86a976e 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_LIBINPUT
        bool "libinput"
+       depends on BR2_ENABLE_LOCALE
        depends on BR2_PACKAGE_HAS_UDEV
        select BR2_PACKAGE_LIBEVDEV
        select BR2_PACKAGE_MTDEV
@@ -13,5 +14,5 @@ config BR2_PACKAGE_LIBINPUT
 
          http://freedesktop.org/wiki/Software/libinput/
 
-comment "libinput needs udev /dev management"
-       depends on !BR2_PACKAGE_HAS_UDEV
+comment "libinput needs udev /dev management and a toolchain w/ locale"
+       depends on !BR2_PACKAGE_HAS_UDEV || !BR2_ENABLE_LOCALE
index 645284712c021b7727ec637c84541e2fece3f9df..299a28f9857d9eb5ae048cf662b9cd746f10f9f3 100644 (file)
@@ -1,2 +1,2 @@
-# From http://lists.freedesktop.org/archives/wayland-devel/2015-April/021485.html
-sha256 2bed202ebe2d5026950d6f9d2ac0f0160d12f61c5a0f6d0d6ef671bbb02c1b64        libinput-0.14.1.tar.xz
+# From http://lists.freedesktop.org/archives/wayland-devel/2015-July/023184.html
+sha256 69a97da47ef8fa9debadaa8ee11005b9b5183bd2b87c5aa7827b7c388a5acc5d        libinput-0.19.0.tar.xz
index bacee6aa3d64ea304ff1cfdb0cde0f44d15ca5cb..175e04f50783327b2e77517879abb39ebe1f07f2 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBINPUT_VERSION = 0.14.1
+LIBINPUT_VERSION = 0.19.0
 LIBINPUT_SOURCE = libinput-$(LIBINPUT_VERSION).tar.xz
 LIBINPUT_SITE = http://www.freedesktop.org/software/libinput
 LIBINPUT_LICENSE = MIT
index dec35839c6a49cf69ccdf8f9598e7355ae9791c9..07773f0a7b778d2607bb942679262cfc06b0c765 100644 (file)
@@ -1,7 +1,8 @@
-comment "weston needs udev and a toolchain w/ threads, dynamic library, headers >= 3.0"
+comment "weston needs udev and a toolchain w/ locale, threads, dynamic library, headers >= 3.0"
        depends on BR2_ARCH_HAS_ATOMICS
        depends on !BR2_PACKAGE_HAS_UDEV || !BR2_TOOLCHAIN_HAS_THREADS || \
-               !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0 || BR2_STATIC_LIBS
+               !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0 || BR2_STATIC_LIBS || \
+               !BR2_ENABLE_LOCALE
 
 config BR2_PACKAGE_WESTON
        bool "weston"
@@ -13,6 +14,7 @@ config BR2_PACKAGE_WESTON
        select BR2_PACKAGE_JPEG
        select BR2_PACKAGE_MTDEV
        select BR2_PACKAGE_LIBINPUT
+       depends on BR2_ENABLE_LOCALE # libinput
        depends on BR2_PACKAGE_HAS_UDEV
        depends on !BR2_STATIC_LIBS # wayland
        depends on BR2_TOOLCHAIN_HAS_THREADS # wayland
index cc878b6e1c7d8bb72b10519ae6ef39bf731fd79a..69697ed0466e473eba8439aac4218c961a4c6151 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_XDRIVER_XF86_INPUT_LIBINPUT
        bool "xf86-input-libinput"
+       depends on BR2_ENABLE_LOCALE # libinput
        depends on BR2_PACKAGE_HAS_UDEV # libinput
        select BR2_PACKAGE_LIBINPUT
        select BR2_PACKAGE_XPROTO_INPUTPROTO
@@ -9,5 +10,5 @@ config BR2_PACKAGE_XDRIVER_XF86_INPUT_LIBINPUT
          libinput, so while it does provide all features that libinput supports
          it does little beyond.
 
-comment "xf86-input-libinput requires udev to be enabled"
-       depends on !BR2_PACKAGE_HAS_UDEV
+comment "xf86-input-libinput needs udev /dev management and a toolchain w/ locale"
+       depends on !BR2_PACKAGE_HAS_UDEV || !BR2_ENABLE_LOCALE