lua: remove 3 sub-options, always install all
authorFrancois Perrad <fperrad@gmail.com>
Mon, 3 Sep 2012 20:58:40 +0000 (20:58 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 15 Nov 2012 11:39:19 +0000 (12:39 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/lua/Config.in
package/lua/lua.mk

index 76359c0df504e6e5295b77da246557250b31bed5..8233e2a69b3f039c7d40fbceaf4da4d8fada268a 100644 (file)
@@ -7,29 +7,11 @@ config BR2_PACKAGE_LUA
 
 if BR2_PACKAGE_LUA
 
-config BR2_PACKAGE_LUA_COMPILER
-       bool "lua compiler"
-       select BR2_PACKAGE_LUA_SHARED_LIBRARY
-       help
-         Install luac binary
-
-config BR2_PACKAGE_LUA_INTERPRETER
-       bool "lua interpreter"
-       select BR2_PACKAGE_LUA_SHARED_LIBRARY
-       help
-         Install lua binary
-
 config BR2_PACKAGE_LUA_INTERPRETER_READLINE
        bool "readline support"
-       depends on BR2_PACKAGE_LUA_INTERPRETER
        select BR2_PACKAGE_READLINE
        select BR2_PACKAGE_NCURSES
        help
          Enables command-line editing in the lua interpreter.
 
-config BR2_PACKAGE_LUA_SHARED_LIBRARY
-       bool "shared library"
-       help
-         Install shared liblua.so
-
 endif
index de60c57e88f8c318fcea4fa6a643278108a87e7f..4704e4caac3e9f2453ac45592de0fb89caa1f84b 100644 (file)
@@ -10,11 +10,7 @@ LUA_INSTALL_STAGING = YES
 LUA_LICENSE = MIT
 LUA_LICENSE_FILES = COPYRIGHT
 
-LUA_CFLAGS = -Wall
-ifeq ($(BR2_PACKAGE_LUA_SHARED_LIBRARY),y)
-       LUA_CFLAGS += -fPIC
-endif
-
+LUA_CFLAGS = -Wall -fPIC
 LUA_MYLIBS += -ldl
 
 ifeq ($(BR2_PACKAGE_LUA_INTERPRETER_READLINE),y)
@@ -46,13 +42,11 @@ define HOST_LUA_BUILD_CMDS
        PKG_VERSION=$(LUA_VERSION) -C $(@D)/src all
 endef
 
-ifeq ($(BR2_PACKAGE_LUA_SHARED_LIBRARY),y)
 define LUA_INSTALL_STAGING_SHARED_LIB
        $(INSTALL) -m 0755 -D $(@D)/src/liblua.so.$(LUA_VERSION) \
                $(STAGING_DIR)/usr/lib/liblua.so.$(LUA_VERSION)
        ln -sf liblua.so.$(LUA_VERSION) $(STAGING_DIR)/usr/lib/liblua.so
 endef
-endif
 
 define LUA_INSTALL_STAGING_CMDS
        $(INSTALL) -m 0644 -D $(@D)/etc/lua.pc \
@@ -66,29 +60,19 @@ define LUA_INSTALL_STAGING_CMDS
        $(INSTALL) -m 0644 -D $(@D)/src/lauxlib.h $(STAGING_DIR)/usr/include/lauxlib.h
 endef
 
-ifeq ($(BR2_PACKAGE_LUA_INTERPRETER),y)
 define LUA_INSTALL_INTERPRETER
        $(INSTALL) -m 0755 -D $(@D)/src/lua $(TARGET_DIR)/usr/bin/lua
 endef
-endif
 
-ifeq ($(BR2_PACKAGE_LUA_COMPILER),y)
 define LUA_INSTALL_COMPILER
        $(INSTALL) -m 0755 -D $(@D)/src/luac $(TARGET_DIR)/usr/bin/luac
 endef
-endif
 
-ifeq ($(BR2_PACKAGE_LUA_SHARED_LIBRARY),y)
 define LUA_INSTALL_LIBRARY
        $(INSTALL) -m 0755 -D $(@D)/src/liblua.so.$(LUA_VERSION) \
                $(TARGET_DIR)/usr/lib/liblua.so.$(LUA_VERSION)
        ln -sf liblua.so.$(LUA_VERSION) $(TARGET_DIR)/usr/lib/liblua.so
        $(INSTALL) -m 0644 -D $(@D)/src/liblua.a $(TARGET_DIR)/usr/lib/liblua.a
-endef
-else
-define LUA_INSTALL_LIBRARY
-       $(INSTALL) -m 0644 -D $(@D)/src/liblua.a $(TARGET_DIR)/usr/lib/liblua.a
-endef
 endif
 
 ifeq ($(BR2_HAVE_DEVFILES),y)