httping: fix static linking when libintl+libiconv are enabled
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 23 May 2014 10:39:35 +0000 (12:39 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 23 May 2014 10:39:35 +0000 (12:39 +0200)
Fixes http://autobuild.buildroot.net/results/365/365d6be787c5560aa1daa28065668261e1171d24/

If libiconv is enabled, libintl will contain references to it, so we need to
explicitly link against it when statically linking against libintl.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/httping/httping.mk

index 610cecb9e3c7b9416b392192a0e02b02d1a5aa3f..ca636c0d2177ed4c89be81dba1f52090469b9680 100644 (file)
@@ -9,9 +9,12 @@ HTTPING_SOURCE = httping-$(HTTPING_VERSION).tgz
 HTTPING_SITE = http://www.vanheusden.com/httping
 HTTPING_LICENSE = GPLv2
 HTTPING_LICENSE_FILES = license.txt
-HTTPING_LDFLAGS = $(if $(BR2_NEEDS_GETTEXT),-lintl) $(TARGET_LDFLAGS)
+HTTPING_LDFLAGS = $(TARGET_LDFLAGS) \
+       $(if $(BR2_NEEDS_GETTEXT),-lintl) \
+       $(if $(BR2_PACKAGE_LIBICONV),-liconv)
 HTTPING_DEPENDENCIES = host-gettext \
        $(if $(BR2_NEEDS_GETTEXT),gettext) \
+       $(if $(BR2_PACKAGE_LIBICONV),libiconv) \
        $(if $(BR2_PACKAGE_OPENSSL),openssl) \
        $(if $(BR2_PACKAGE_FFTW),fftw)
 HTTPING_MAKE_OPT = $(TARGET_CONFIGURE_OPTS) \