package/speex: use pkgconf to detect libogg
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 10 Jun 2018 10:10:23 +0000 (12:10 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 10 Jun 2018 11:24:48 +0000 (13:24 +0200)
Upstream removed with-ogg-* configure options and switched to pkgconf
to detect libogg back in 2014:
https://git.xiph.org/?p=speex.git;a=commitdiff;h=e1b1eeabce815283c5bbc42016a9d6a11eda2866

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/speex/speex.mk

index 3c188b631e39838d112d6406d2620260aba41d65..516e89929afe18ebfab2339780440e572a4791a2 100644 (file)
@@ -8,12 +8,9 @@ SPEEX_VERSION = 1.2rc1
 SPEEX_SITE = http://downloads.us.xiph.org/releases/speex
 SPEEX_LICENSE = BSD-3-Clause
 SPEEX_LICENSE_FILES = COPYING
-
 SPEEX_INSTALL_STAGING = YES
-SPEEX_DEPENDENCIES = libogg
+SPEEX_DEPENDENCIES = host-pkgconf libogg
 SPEEX_CONF_OPTS = \
-       --with-ogg-libraries=$(STAGING_DIR)/usr/lib \
-       --with-ogg-includes=$(STAGING_DIR)/usr/include \
        --enable-fixed-point
 
 ifeq ($(BR2_PACKAGE_SPEEX_ARM4),y)