u-boot: add an option to indicate that DTC is needed
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 3 Oct 2015 19:44:13 +0000 (20:44 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 4 Oct 2015 18:17:35 +0000 (20:17 +0200)
Some U-Boot configurations require the Device Tree compiler to be
available, so we need to depend on host-dtc (example configuration:
zynq_zed).

However, we don't want to build it unconditionally, since the vast
majority of U-Boot configurations don't need it (and host-dtc itself
has a bunch of dependencies).

So, we simply add a Config.in option that allows users to indicate
whether their U-Boot needs DTC or not, and depend on host-dtc if this
option is enabled.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
boot/uboot/Config.in
boot/uboot/uboot.mk

index be51642918315f4df08cb85a5de446b2d046758d..8643dab36a9173bbd279b8bf81d5eaedd16edd8d 100644 (file)
@@ -139,6 +139,13 @@ config BR2_TARGET_UBOOT_CUSTOM_CONFIG_FILE
          Path to the U-Boot configuration file.
 endif
 
+config BR2_TARGET_UBOOT_NEEDS_DTC
+       bool "U-Boot needs dtc"
+       select BR2_PACKAGE_HOST_DTC
+       help
+         Select this option if your U-Boot board configuration
+         requires the Device Tree compiler to be available.
+
 choice
        prompt "U-Boot binary format"
        default BR2_TARGET_UBOOT_FORMAT_BIN
index 74940788ce1bc77e549bffb2c546f68c080bf7e8..eee0dba23b3a93962a5053962bc28fc0a77bc256 100644 (file)
@@ -77,6 +77,10 @@ UBOOT_MAKE_OPTS += \
        CROSS_COMPILE="$(TARGET_CROSS)" \
        ARCH=$(UBOOT_ARCH)
 
+ifeq ($(BR2_TARGET_UBOOT_NEEDS_DTC),y)
+UBOOT_DEPENDENCIES += host-dtc
+endif
+
 # Helper function to fill the U-Boot config.h file.
 # Argument 1: option name
 # Argument 2: option value