infra: support buildroot being located in /usr
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Sat, 21 Jun 2014 15:01:47 +0000 (17:01 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 29 Jun 2014 10:38:17 +0000 (12:38 +0200)
pkg-generic and pkg-autotools both perform sed replacements of /usr to
$(STAGING_DIR)/usr, in .pc and .la files respectively. However, if buildroot
itself is located in /usr, then STAGING_DIR also starts with /usr, and naive
replacements of '/usr' can result in paths of the form:
    /usr/buildroot/.../sysroot/usr/buildroot/.../sysroot/...

This patch makes the replacements more careful, by first replacing the known
paths BASE_DIR and STAGING_DIR to tokens, then performing the actual
replacement, and finally replacing the tokens with the corresponding paths.

Additionally it removes the unnecessary making of a backup copy in
pkg-autotools.

Partially fixes bug #5750 (https://bugs.busybox.net/show_bug.cgi?id=5750)

[Thomas: improve pkg-autotools.mk by including the explanation comment
proposed by Arnout.]

Partially-based-on-a-patch-from: Ben Stoltz <benstoltz@gmail.com>
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-autotools.mk
package/pkg-generic.mk

index e27ec1f0dfdcbe89fe9c16783f6448a0a314cb1d..8527314276340a88925011e398069d07b15b5d26 100644 (file)
@@ -264,12 +264,27 @@ endif
 # Staging installation step. Only define it if not already defined by
 # the package .mk file.
 #
+# Most autotools packages install libtool .la files alongside any
+# installed libraries. These .la files sometimes refer to paths
+# relative to the sysroot, which libtool will interpret as absolute
+# paths to host libraries instead of the target libraries. Since we
+# configure with --prefix=/usr, such absolute paths start with
+# /usr. So we add $(STAGING_DIR) in front of any path that starts with
+# /usr.
+#
+# To protect against the case that the output directory itself is
+# under /usr, we first substitute away any occurences of the output
+# directory to @BASE_DIR@.
+#
 ifndef $(2)_INSTALL_STAGING_CMDS
 define $(2)_INSTALL_STAGING_CMDS
        $$(TARGET_MAKE_ENV) $$($$(PKG)_MAKE_ENV) $$($$(PKG)_MAKE) $$($$(PKG)_INSTALL_STAGING_OPT) -C $$($$(PKG)_SRCDIR)
        for i in $$$$(find $$(STAGING_DIR)/usr/lib* -name "*.la"); do \
-               cp -f $$$$i $$$$i~; \
-               $$(SED) "s:\(['= ]\)/usr:\\1$$(STAGING_DIR)/usr:g" $$$$i; \
+               $$(SED) "s:$$(BASE_DIR):@BASE_DIR@:g" \
+                       -e "s:\(['= ]\)/usr:\\1@STAGING_DIR@/usr:g" \
+                       -e "s:@STAGING_DIR@:$$(STAGING_DIR):g" \
+                       -e "s:@BASE_DIR@:$$(BASE_DIR):g" \
+                       $$$$i; \
        done
 endef
 endif
index 78fe1346ce8b7f870eebf63e76e961e7c0456b2a..54193d25a22013ffe9a1045e94833c8590c1a678 100644 (file)
@@ -201,9 +201,12 @@ $(BUILD_DIR)/%/.stamp_staging_installed:
        $(foreach hook,$($(PKG)_POST_INSTALL_STAGING_HOOKS),$(call $(hook))$(sep))
        $(Q)if test -n "$($(PKG)_CONFIG_SCRIPTS)" ; then \
                $(call MESSAGE,"Fixing package configuration files") ;\
-                       $(SED)  "s,^\(exec_\)\?prefix=.*,\1prefix=$(STAGING_DIR)/usr,g" \
-                               -e "s,-I/usr/,-I$(STAGING_DIR)/usr/,g" \
-                               -e "s,-L/usr/,-L$(STAGING_DIR)/usr/,g" \
+                       $(SED)  "s,$(BASE_DIR),@BASE_DIR@,g" \
+                               -e "s,^\(exec_\)\?prefix=.*,\1prefix=@STAGING_DIR@/usr,g" \
+                               -e "s,-I/usr/,-I@STAGING_DIR@/usr/,g" \
+                               -e "s,-L/usr/,-L@STAGING_DIR@/usr/,g" \
+                               -e "s,@STAGING_DIR@,$(STAGING_DIR),g" \
+                               -e "s,@BASE_DIR@,$(BASE_DIR),g" \
                                $(addprefix $(STAGING_DIR)/usr/bin/,$($(PKG)_CONFIG_SCRIPTS)) ;\
        fi
        $(Q)touch $@