projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
664c370
)
package/libselinux: enable kernel selinux support for jffs2 images
author
Adam Duskett
<Aduskett@gmail.com>
Fri, 31 Jul 2020 20:40:58 +0000
(13:40 -0700)
committer
Thomas Petazzoni
<thomas.petazzoni@bootlin.com>
Fri, 4 Sep 2020 13:43:49 +0000
(15:43 +0200)
If BR2_TARGET_ROOTFS_JFFS2 is selected, enable the following kernel options:
- CONFIG_JFS_SECURITY
Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libselinux/libselinux.mk
patch
|
blob
|
history
diff --git
a/package/libselinux/libselinux.mk
b/package/libselinux/libselinux.mk
index c16dcdf1d00eba7e1906d4244a2d895cbbe2a496..3dee9222147252b6124184995ca0cfe642c26469 100644
(file)
--- a/
package/libselinux/libselinux.mk
+++ b/
package/libselinux/libselinux.mk
@@
-125,6
+125,8
@@
define LIBSELINUX_LINUX_CONFIG_FIXUPS
$(if $(BR2_TARGET_ROOTFS_F2FS),
$(call KCONFIG_ENABLE_OPT,CONFIG_F2FS_FS_XATTR)
$(call KCONFIG_ENABLE_OPT,CONFIG_F2FS_FS_SECURITY))
+ $(if $(BR2_TARGET_ROOTFS_JFFS2),
+ $(call KCONFIG_ENABLE_OPT,CONFIG_JFS_SECURITY))
endef
$(eval $(generic-package))