package/python-intelhex: bump to version 2.3.0
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 25 Oct 2020 22:39:57 +0000 (23:39 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 26 Oct 2020 21:09:13 +0000 (22:09 +0100)
Fix Python 3.9 compatibility issue with 'array' module

https://github.com/python-intelhex/intelhex/releases/tag/2.3.0

Fixes:
 - http://autobuild.buildroot.org/results/1c217f0c67c63ee43494ef84af832df8e856e2df

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: Marcin Niestroj <m.niestroj@grinn-global.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python-intelhex/Config.in
package/python-intelhex/python-intelhex.hash
package/python-intelhex/python-intelhex.mk

index 20dbb8c9cad68100db89f2267ffcea93419a5d32..d67de822f28325100045af4e02a36ef64115b4a4 100644 (file)
@@ -3,4 +3,4 @@ config BR2_PACKAGE_PYTHON_INTELHEX
        help
          Python library for Intel HEX files manipulations.
 
-         https://pypi.python.org/pypi/IntelHex
+         https://github.com/python-intelhex/intelhex
index 80674f14aeed663dcb4c31a5940eb5786922e515..917bd72cd75f2084fe22b180ec1292d4f41e0b80 100644 (file)
@@ -1,5 +1,5 @@
 # md5, sha256 from https://pypi.org/pypi/intelhex/json
-md5  9ce7402e0fd33249aef52cbf437b4ab7  intelhex-2.2.1.tar.gz
-sha256  009d8511e0d50639230c39af9607deee771cf026f67ef7507a8c3fd4fa927832  intelhex-2.2.1.tar.gz
+md5  9de0e92c1b66f75322581c8b22c020c2  intelhex-2.3.0.tar.gz
+sha256  892b7361a719f4945237da8ccf754e9513db32f5628852785aea108dcd250093  intelhex-2.3.0.tar.gz
 # Locally computed sha256 checksums
 sha256  1b2eb032ab8a1b0266f7995c76e44509f89ca9c0e90ec507763b5e735aca7de4  LICENSE.txt
index 64b21270e13ea5b3b79b827174eca718ebd581d0..cc8b973f0f2d58f27a0b613c46c6ac80ca4ffa38 100644 (file)
@@ -4,10 +4,10 @@
 #
 ################################################################################
 
-PYTHON_INTELHEX_VERSION = 2.2.1
+PYTHON_INTELHEX_VERSION = 2.3.0
 PYTHON_INTELHEX_SOURCE = intelhex-$(PYTHON_INTELHEX_VERSION).tar.gz
-PYTHON_INTELHEX_SITE = https://files.pythonhosted.org/packages/01/66/8fab869edcc0eaf8fc030472ff379b8eeee2ef3b42f8aec6bd84e9f735e3
-PYTHON_INTELHEX_SETUP_TYPE = distutils
+PYTHON_INTELHEX_SITE = https://files.pythonhosted.org/packages/66/37/1e7522494557d342a24cb236e2aec5d078fac8ed03ad4b61372586406b01
+PYTHON_INTELHEX_SETUP_TYPE = setuptools
 PYTHON_INTELHEX_LICENSE = BSD-3-Clause
 PYTHON_INTELHEX_LICENSE_FILES = LICENSE.txt