package/glslsandbox-player: add mali-t76x support
authorJulien Olivain <ju.o@free.fr>
Fri, 3 Sep 2021 19:50:20 +0000 (21:50 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 5 Sep 2021 14:03:51 +0000 (16:03 +0200)
mali-t76x frame buffer driver requires a "null" native windowing
system. With such a system, the default EGL display is selected.

Fixes:
http://autobuild.buildroot.net/results/4a579346463d0d946d6d2a05723270135d728981

Signed-off-by: Julien Olivain <ju.o@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/glslsandbox-player/Config.in
package/glslsandbox-player/glslsandbox-player.mk

index dc0d2c07f1b9ad513f2194e215934dbc29c256cc..8ab668d26046be0f8e1de126b9d6fd2da7564ed3 100644 (file)
@@ -56,6 +56,7 @@ config BR2_PACKAGE_GLSLSANDBOX_PLAYER_SCRIPTS
 choice
        prompt "Native windowing system"
        default BR2_PACKAGE_GLSLSANDBOX_PLAYER_MALI  if BR2_PACKAGE_SUNXI_MALI_MAINLINE
+       default BR2_PACKAGE_GLSLSANDBOX_PLAYER_MALI_T76X if BR2_PACKAGE_MALI_T76X
        default BR2_PACKAGE_GLSLSANDBOX_PLAYER_RPI   if BR2_PACKAGE_RPI_USERLAND
        default BR2_PACKAGE_GLSLSANDBOX_PLAYER_SDL2  if BR2_PACKAGE_SDL2_OPENGLES
        default BR2_PACKAGE_GLSLSANDBOX_PLAYER_TISGX if BR2_PACKAGE_TI_SGX_UM
@@ -73,6 +74,10 @@ config BR2_PACKAGE_GLSLSANDBOX_PLAYER_MALI
        bool "Allwinner ARM/Mali Frame Buffer"
        depends on BR2_PACKAGE_SUNXI_MALI_MAINLINE
 
+config BR2_PACKAGE_GLSLSANDBOX_PLAYER_MALI_T76X
+       bool "ARM/Mali T76x Frame Buffer"
+       depends on BR2_PACKAGE_MALI_T76X
+
 config BR2_PACKAGE_GLSLSANDBOX_PLAYER_RPI
        bool "RaspberryPI Frame Buffer"
        depends on BR2_PACKAGE_RPI_USERLAND
index 341b93911078682a014b742da0e0c04c23ec5765..1578608a428656b84e549e99d56747a7ec3716e9 100644 (file)
@@ -44,6 +44,9 @@ GLSLSANDBOX_PLAYER_CONF_OPTS += --with-native-gfx=kms
 else ifeq ($(BR2_PACKAGE_GLSLSANDBOX_PLAYER_MALI),y)
 GLSLSANDBOX_PLAYER_DEPENDENCIES += sunxi-mali-mainline
 GLSLSANDBOX_PLAYER_CONF_OPTS += --with-native-gfx=mali
+else ifeq ($(BR2_PACKAGE_GLSLSANDBOX_PLAYER_MALI_T76X),y)
+GLSLSANDBOX_PLAYER_DEPENDENCIES += mali-t76x
+GLSLSANDBOX_PLAYER_CONF_OPTS += --with-native-gfx=nullws
 else ifeq ($(BR2_PACKAGE_GLSLSANDBOX_PLAYER_RPI),y)
 GLSLSANDBOX_PLAYER_DEPENDENCIES += rpi-userland
 GLSLSANDBOX_PLAYER_CONF_OPTS += --with-native-gfx=rpi