package/solarus: bump to version 1.6.4
authorRomain Naour <romain.naour@gmail.com>
Mon, 4 May 2020 14:37:42 +0000 (16:37 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 5 May 2020 19:37:31 +0000 (21:37 +0200)
Add glm dependency since the bundled version is gone [1].

Update indentation of hash file (two spaces).

[1] https://gitlab.com/solarus-games/solarus/commit/5285c8e1afa538bbcd4c8654f9bbfb270cc7f52

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/solarus/Config.in
package/solarus/solarus.hash
package/solarus/solarus.mk

index 6bed38a6f551b3d36d0fea2f132d5c3d2af22498..5d15342f3aa619ae4561b7f1c7d6fcc81972d1c7 100644 (file)
@@ -7,6 +7,7 @@ config BR2_PACKAGE_SOLARUS
        depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL # openal
        depends on !BR2_STATIC_LIBS # SDL2
        depends on BR2_PACKAGE_HAS_LIBGL
+       select BR2_PACKAGE_GLM
        select BR2_PACKAGE_LIBMODPLUG
        select BR2_PACKAGE_LIBOGG
        select BR2_PACKAGE_LIBPNG # runtime
index 3092b135076eec4a5a349a466c6dd871795e1bb8..8400bfd135b4b6053cef89f902769f4ccb76d61b 100644 (file)
@@ -1,4 +1,4 @@
 # Locally calculated
-sha256 c14cd97bad6e12310b938d90abd4e8ebdd0abb403cdcc015d5add82dfc5a085b  solarus-v1.6.2.tar.bz2
+sha256  b2e00a7df8953903ba022a8f392038e86f675cee714da19cf9a5f8535c42f349  solarus-v1.6.4.tar.bz2
 
-sha256 309875d925041d909bc705473d6c4b7905272aea15c1c2389088c26c161bae1f  license.txt
+sha256  309875d925041d909bc705473d6c4b7905272aea15c1c2389088c26c161bae1f  license.txt
index 6f5853e90976b6cbbac93b157a133a3853890ad8..92e849ef0266eb339b14d6d69b64d2bb2f3b1fb7 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-SOLARUS_VERSION = 1.6.2
+SOLARUS_VERSION = 1.6.4
 SOLARUS_SITE = \
        https://gitlab.com/solarus-games/solarus/-/archive/v$(SOLARUS_VERSION)
 SOLARUS_SOURCE = solarus-v$(SOLARUS_VERSION).tar.bz2
@@ -16,8 +16,8 @@ SOLARUS_LICENSE_FILES = license.txt
 # Install libsolarus.so
 SOLARUS_INSTALL_STAGING = YES
 
-SOLARUS_DEPENDENCIES = libgl libmodplug libogg libvorbis openal physfs sdl2 \
-       sdl2_image sdl2_ttf
+SOLARUS_DEPENDENCIES = glm libgl libmodplug libogg libvorbis openal physfs \
+       sdl2 sdl2_image sdl2_ttf
 
 # Disable launcher GUI (requires Qt5)
 SOLARUS_CONF_OPTS = \