efl/libevas: adjust dependency on X11 libraries
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 28 Dec 2012 15:35:44 +0000 (16:35 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Dec 2012 06:21:58 +0000 (07:21 +0100)
The libevas configure script actually checks the presence of libX11
and libXext, so use those two libraries as the dependencies for the
X11 backend of libevas.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efl/libevas/Config.in
package/efl/libevas/libevas.mk

index d8e5002dac11a1e1c591565cc3fdbbea515c90b7..bd845c1154e9b958bc6078c8628c9545a346d8af 100644 (file)
@@ -91,6 +91,7 @@ config BR2_PACKAGE_LIBEVAS_X11
        bool "libevas X11 backend"
        depends on BR2_PACKAGE_XORG7
        select BR2_PACKAGE_XLIB_LIBX11
+       select BR2_PACKAGE_XLIB_LIBXEXT
        help
          This enables the software X11 rendering engine that renders
          to X drawable targets using highly optimised software
index 6e69d7ff83643decff1710710db57287dd1537fc..098afe3f95ca4336899ca70676bfb2e4b7568347 100644 (file)
@@ -63,7 +63,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_LIBEVAS_X11),y)
 LIBEVAS_CONF_OPT += --enable-software-xlib
-LIBEVAS_DEPENDENCIES += xproto_xproto
+LIBEVAS_DEPENDENCIES += xlib_libX11 xlib_libXext
 endif
 
 ifeq ($(BR2_PACKAGE_LIBEVAS_X11_GLX),y)