libsepol: really fix static library build
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 20 Feb 2014 21:42:36 +0000 (22:42 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 20 Feb 2014 21:50:42 +0000 (22:50 +0100)
In commit 52eeb04c7608b9675bd8c2d57d3a4d1373ee72ad ('libsepol: fix
static-only library build') I forgot to git add the changes made to
the libsepol.mk file itself. Those changes are needed to actually pass
STATIC=<something> when building static libraries only.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libsepol/libsepol.mk

index c359cd7e452c4757e5b1c8e7aae8c53495337f1e..19b193c79d40dfac95c9c017761812f4dc182493 100644 (file)
@@ -11,18 +11,24 @@ LIBSEPOL_LICENSE_FILES = COPYING
 
 LIBSEPOL_INSTALL_STAGING = YES
 
+LIBSEPOL_MAKE_FLAGS = $(TARGET_CONFIGURE_OPTS)
+
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+LIBSEPOL_MAKE_FLAGS += STATIC=1
+endif
+
 define LIBSEPOL_BUILD_CMDS
        # DESTDIR is needed during the compile to compute library and
        # header paths.
-       $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) DESTDIR=$(STAGING_DIR)
+       $(MAKE) -C $(@D) $(LIBSEPOL_MAKE_FLAGS) DESTDIR=$(STAGING_DIR)
 endef
 
 define LIBSEPOL_INSTALL_STAGING_CMDS
-       $(MAKE) -C $(@D) install $(TARGET_CONFIGURE_OPTS) DESTDIR=$(STAGING_DIR)
+       $(MAKE) -C $(@D) install $(LIBSEPOL_MAKE_FLAGS) DESTDIR=$(STAGING_DIR)
 endef
 
 define LIBSEPOL_INSTALL_TARGET_CMDS
-       $(MAKE) -C $(@D) install $(TARGET_CONFIGURE_OPTS) DESTDIR=$(TARGET_DIR)
+       $(MAKE) -C $(@D) install $(LIBSEPOL_MAKE_FLAGS) DESTDIR=$(TARGET_DIR)
 endef
 
 define HOST_LIBSEPOL_BUILD_CMDS