package/python-aioconsole: new package
authorJames Hilliard <james.hilliard1@gmail.com>
Sun, 3 Mar 2019 23:44:19 +0000 (07:44 +0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 17 Mar 2019 15:24:08 +0000 (16:24 +0100)
Asynchronous console and interfaces for asyncio.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-aioconsole/Config.in [new file with mode: 0644]
package/python-aioconsole/python-aioconsole.hash [new file with mode: 0644]
package/python-aioconsole/python-aioconsole.mk [new file with mode: 0644]

index 359f04490ce4be4a73f894d4274f077fe015cdd2..ae1d97152cfc147cada856d938310044d8327584 100644 (file)
@@ -1033,6 +1033,7 @@ F:        configs/pine64_sopine_defconfig
 N:     James Hilliard <james.hilliard1@gmail.com>
 F:     package/lua-std-debug/
 F:     package/lua-std-normalize/
+F:     package/python-aioconsole/
 F:     package/python-aiodns/
 F:     package/python-aiohttp/
 F:     package/python-aiohttp-cors/
index 457018b18e6fdaeb5c19db8468f7d37ae67141e0..2407c12b529413b115e8e808e23b8eef4d05a8e4 100644 (file)
@@ -800,6 +800,7 @@ if BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3
 menu "External python modules"
        source "package/python-aioblescan/Config.in"
        source "package/python-aiocoap/Config.in"
+       source "package/python-aioconsole/Config.in"
        source "package/python-aiodns/Config.in"
        source "package/python-aiohttp/Config.in"
        source "package/python-aiohttp-cors/Config.in"
diff --git a/package/python-aioconsole/Config.in b/package/python-aioconsole/Config.in
new file mode 100644 (file)
index 0000000..cd52eec
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_AIOCONSOLE
+       bool "python-aioconsole"
+       depends on BR2_PACKAGE_PYTHON3
+       help
+         Asynchronous console and interfaces for asyncio.
+
+         https://github.com/vxgmichel/aioconsole
diff --git a/package/python-aioconsole/python-aioconsole.hash b/package/python-aioconsole/python-aioconsole.hash
new file mode 100644 (file)
index 0000000..0e09cfb
--- /dev/null
@@ -0,0 +1,3 @@
+# md5, sha256 from https://pypi.org/pypi/aioconsole/json
+md5    212dc49e2f2a995c87ce659ba63e7422  aioconsole-0.1.13.tar.gz
+sha256 8b9898f0f6539bdce3bc3720d75189e21813f1a7f8350228fc7fd54bf7327d0f  aioconsole-0.1.13.tar.gz
diff --git a/package/python-aioconsole/python-aioconsole.mk b/package/python-aioconsole/python-aioconsole.mk
new file mode 100644 (file)
index 0000000..47245d2
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-aioconsole
+#
+################################################################################
+
+PYTHON_AIOCONSOLE_VERSION = 0.1.13
+PYTHON_AIOCONSOLE_SOURCE = aioconsole-$(PYTHON_AIOCONSOLE_VERSION).tar.gz
+PYTHON_AIOCONSOLE_SITE = https://files.pythonhosted.org/packages/ea/ee/80154d7242c2107d02768c5a848e4cded39ce8cd89b48982c217474c8ddd
+PYTHON_AIOCONSOLE_SETUP_TYPE = setuptools
+PYTHON_AIOCONSOLE_LICENSE = GPL-3.0
+
+$(eval $(python-package))