Revert "tslib: needs kernel headers 3.12"
authorMartin Kepplinger <martin.kepplinger@ginzinger.com>
Thu, 9 Feb 2017 05:55:04 +0000 (07:55 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 9 Feb 2017 08:32:09 +0000 (09:32 +0100)
This reverts commit 7c60211ce38273580f1f8bf5886771406f9899ca.

tslib-1.4 removes this dependency.

Add upstream patch that fixes input macros declaration for older kernels.

The ts_uinput tool requires 3.6 headers; disable for older kernels.

Signed-off-by: Martin Kepplinger <martin.kepplinger@ginzinger.com>
[baruch: add tslib patch; disable ts_uinput]
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/directfb/Config.in
package/qt/Config.mouse.in
package/qt5/qt5base/Config.in
package/tslib/Config.in
package/tslib/tslib.hash
package/tslib/tslib.mk
package/x11r7/xdriver_xf86-input-tslib/Config.in

index 35c0309a6f3684cfbed9cf6e6650d4687354ed51..b5521647772da82b120a258984a9e4cbe85729da 100644 (file)
@@ -113,12 +113,11 @@ config BR2_PACKAGE_DIRECTFB_SERIALMOUSE
 config BR2_PACKAGE_DIRECTFB_TSLIB
        bool "enable touchscreen support"
        depends on !BR2_STATIC_LIBS # tslib
-       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12 # tslib
        default y
        select BR2_PACKAGE_TSLIB
 
-comment "touchscreen support needs a toolchain w/ dynamic library, headers >= 3.12"
-       depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12
+comment "touchscreen support needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
 
 config BR2_PACKAGE_DIRECTFB_GIF
        bool "enable GIF support"
index f15f8d5f56811b5a41b3e5e95831d97740c7b4a6..11da956f62f6eab0eb41363c65957b8e893606c8 100644 (file)
@@ -13,10 +13,9 @@ config BR2_PACKAGE_QT_MOUSE_TSLIB
        bool "tslib"
        select BR2_PACKAGE_TSLIB
        depends on !BR2_STATIC_LIBS # tslib
-       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12 # tslib
 
-comment "tslib support needs a toolchain w/ dynamic library, headers >= 3.12"
-       depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12
+comment "tslib support needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
 
 config BR2_PACKAGE_QT_MOUSE_QVFB
        bool "qvfb"
index e273caa7733f69fbfab438b051c8f80d7a24866e..f22e034b3086710c0cbc57b73b8972860e634295 100644 (file)
@@ -278,12 +278,11 @@ config BR2_PACKAGE_QT5BASE_ICU
 config BR2_PACKAGE_QT5BASE_TSLIB
        bool "Enable Tslib support"
        depends on !BR2_STATIC_LIBS # dlopen
-       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12 # tslib
        select BR2_PACKAGE_TSLIB
        help
          This options enables the Tslib plugin
 
-comment "tslib support needs a toolchain w/ dynamic library, headers >= 3.12"
-       depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12
+comment "tslib support needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
 
 endif
index 366530143d151bde77ba7a416ec6db601ff599e7..bc5d7901888c3baf5799b4b6e826cab5f19dda11 100644 (file)
@@ -1,11 +1,10 @@
 config BR2_PACKAGE_TSLIB
        bool "tslib"
        depends on !BR2_STATIC_LIBS # dlopen
-       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12
        help
          Tslib is a filtering layer for touchscreen panel events.
 
          https://github.com/kergoth/tslib
 
-comment "tslib needs a toolchain w/ dynamic library, headers >= 3.12"
-       depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12
+comment "tslib needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
index 6540ac89b39c2fd0e290747b69bb1e06e90d0363..b731df290a68ea83b0f975475fdd075b6df51378 100644 (file)
@@ -1,2 +1,4 @@
 # taken from https://github.com/kergoth/tslib/releases/tag/1.4
 sha256  ad0373f1dbfda27caec92cb10421227f226c79d160488f1ac915585ba947741f  tslib-1.4.tar.xz
+# Locally computed
+sha256 b76d25358d1e2bbcc88b0b225e8d71cd00a4795f6d17020bae270940b17d0825  02795c4fa8b842c6fc017e86b5e036466bd4d3ef.patch
index 5ea526e5700ac230f8830f6e36c47b24f10674c0..356c4c2d92644ec4d412c24d3f0c8a3686a0bfff 100644 (file)
@@ -10,8 +10,13 @@ TSLIB_SOURCE = tslib-$(TSLIB_VERSION).tar.xz
 TSLIB_LICENSE = GPL, LGPL
 TSLIB_LICENSE_FILES = COPYING
 
+TSLIB_PATCH = https://github.com/kergoth/tslib/commit/02795c4fa8b842c6fc017e86b5e036466bd4d3ef.patch
 TSLIB_AUTORECONF = YES
 TSLIB_INSTALL_STAGING = YES
 TSLIB_INSTALL_STAGING_OPTS = DESTDIR=$(STAGING_DIR) LDFLAGS=-L$(STAGING_DIR)/usr/lib install
 
+ifeq ($(BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_6),)
+TSLIB_CONF_OPTS += --disable-tools
+endif
+
 $(eval $(autotools-package))
index 79b739686ec38675ed03f3b2887178e6a634282a..9c6e2961537c70e4eac1409403eda4d3f73e2f0d 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_XDRIVER_XF86_INPUT_TSLIB
        bool "xf86-input-tslib"
        depends on !BR2_STATIC_LIBS # tslib
-       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12 # tslib
        select BR2_PACKAGE_XPROTO_INPUTPROTO
        select BR2_PACKAGE_XPROTO_RANDRPROTO
        select BR2_PACKAGE_XPROTO_XPROTO
@@ -11,5 +10,5 @@ config BR2_PACKAGE_XDRIVER_XF86_INPUT_TSLIB
 
          http://www.ptxdist.org/software/xf86-input-tslib/index_en.html
 
-comment "xf86-input-tslib needs a toolchain w/ dynamic library, headers >= 3.12"
-       depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12
+comment "xf86-input-tslib needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS