sunxi-mali: fix linking of malitest
authorFrancois Perrad <fperrad@gmail.com>
Tue, 30 Jun 2015 15:48:17 +0000 (17:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 30 Jun 2015 16:55:59 +0000 (18:55 +0200)
Fixes:

  http://autobuild.buildroot.net/results/a15/a152beb56cdc4591868e14cce9a60e51cbfb0abc/

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sunxi-mali/0002-linking-of-test-app-needs-libUMP.patch [new file with mode: 0644]

diff --git a/package/sunxi-mali/0002-linking-of-test-app-needs-libUMP.patch b/package/sunxi-mali/0002-linking-of-test-app-needs-libUMP.patch
new file mode 100644 (file)
index 0000000..1c8f7ee
--- /dev/null
@@ -0,0 +1,18 @@
+linking of test app needs libUMP
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+diff --git a/test/Makefile b/test/Makefile
+index 700416e..92085cb 100644
+--- a/test/Makefile
++++ b/test/Makefile
+@@ -5,7 +5,7 @@
+ all: test
+ test: ../config.mk test.c
+-      $(CC) $(CFLAGS) -o $@ test.c -lEGL -lGLESv2
++      $(CC) $(CFLAGS) -o $@ test.c -lEGL -lGLESv2 -lUMP
+ clean:
+       rm -f test
+