package/gcc: remove libmudflap option
authorRomain Naour <romain.naour@smile.fr>
Fri, 2 Aug 2019 13:09:32 +0000 (15:09 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 2 Aug 2019 20:51:54 +0000 (22:51 +0200)
libmudflap was removed from gcc 4.9 [1] so it depends on gcc <= 4.9.
This option can't be selected since we removed gcc 4.8 from Buildroot
[2].

[1] 4a692aefee10088c385d30e829abf80af1616d1b
[2] f66952197b41452b77dfa065adc7172137e4c243

Signed-off-by: Romain Naour <romain.naour@smile.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gcc/Config.in.host
package/gcc/gcc-final/gcc-final.mk
package/gcc/gcc.mk

index a3ba7cf90d8dabc656127dc1faee2ed4d6e163ea..15ce7b81b524fb723ea75f16eec6291fd1cf908f 100644 (file)
@@ -154,22 +154,6 @@ config BR2_GCC_ENABLE_OPENMP
        help
          Enable OpenMP support for the compiler
 
-config BR2_GCC_ENABLE_LIBMUDFLAP
-       bool "Enable libmudflap support"
-       # There are architectures, or specific configurations for
-       # which mudflap is not supported.
-       depends on !BR2_ARM_INSTRUCTIONS_THUMB && !BR2_powerpc_SPE
-       depends on !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
-       help
-         libmudflap is a gcc library used for the mudflap pointer
-         debugging functionality. It is only needed if you intend to
-         use the -fmudflap gcc flag.
-
-         See http://gcc.gnu.org/wiki/Mudflap_Pointer_Debugging and
-         the help of the gcc -fmudflap option for more details.
-
-         If you're unsure, leave this option disabled.
-
 config BR2_GCC_ENABLE_GRAPHITE
        bool "Enable graphite support"
        depends on BR2_TOOLCHAIN_GCC_AT_LEAST_5
index 49f16f699e96ea63bc6fb2897fd4590d25a24972..f478fde0d76f46113a5045cab6db775154342dd6 100644 (file)
@@ -184,14 +184,6 @@ ifeq ($(BR2_GCC_ENABLE_OPENMP),y)
 HOST_GCC_FINAL_USR_LIBS += libgomp
 endif
 
-ifeq ($(BR2_GCC_ENABLE_LIBMUDFLAP),y)
-ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
-HOST_GCC_FINAL_USR_LIBS += libmudflapth
-else
-HOST_GCC_FINAL_USR_LIBS += libmudflap
-endif
-endif
-
 ifneq ($(HOST_GCC_FINAL_USR_LIBS),)
 define HOST_GCC_FINAL_INSTALL_STATIC_LIBS
        for i in $(HOST_GCC_FINAL_USR_LIBS) ; do \
index 46ad16df137ef1b0f59e1bef0a911cf2c9dca313..20ef544ef5bbdb341b43e96ce5812ad7494fdf98 100644 (file)
@@ -155,12 +155,6 @@ ifeq ($(BR2_GCC_ENABLE_LTO),y)
 HOST_GCC_COMMON_CONF_OPTS += --enable-plugins --enable-lto
 endif
 
-ifeq ($(BR2_GCC_ENABLE_LIBMUDFLAP),y)
-HOST_GCC_COMMON_CONF_OPTS += --enable-libmudflap
-else
-HOST_GCC_COMMON_CONF_OPTS += --disable-libmudflap
-endif
-
 ifeq ($(BR2_PTHREADS_NONE),y)
 HOST_GCC_COMMON_CONF_OPTS += \
        --disable-threads \