cmake: pass LDFLAGS/CFLAGS when building for the host
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 25 Jun 2010 09:41:56 +0000 (11:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 7 Jul 2010 06:14:02 +0000 (08:14 +0200)
Passing LDFLAGS/CFLAGS when building for the host allows cmake to be
compiled with the proper -rpath value (the -rpath option is added to
HOST_LDFLAGS in a later commit).

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cmake/cmake.mk

index 42d4ff5ed7ea821a17936944e3309a3a517780c2..b388874aefcae2d71d417cdde9da28a832052de6 100644 (file)
@@ -4,7 +4,9 @@ CMAKE_SITE=http://www.cmake.org/files/v2.8/
 
 define HOST_CMAKE_CONFIGURE_CMDS
  (cd $(@D); \
-   ./bootstrap --prefix=$(HOST_DIR)/usr --parallel=$(BR2_JLEVEL) \
+       LDFLAGS="$(HOST_LDFLAGS)" \
+       CFLAGS="$(HOST_CFLAGS)" \
+       ./bootstrap --prefix=$(HOST_DIR)/usr --parallel=$(BR2_JLEVEL) \
  )
 endef