package/libiconv: bump to 1.15
authorRomain Naour <romain.naour@gmail.com>
Sat, 3 Jun 2017 21:47:44 +0000 (23:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Jun 2017 07:38:01 +0000 (09:38 +0200)
libiconv doesn't build with gcc 6 due to a macro in stdio.h using gets()
which has been removed with the C11 standard.

_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");

With libiconv 1.15, this macro is protected by

 #if HAVE_RAW_DECL_GETS && !defined __cplusplus
 _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
 #endif

Fixes:
http://autobuild.buildroot.net/results/61b/61bbfc839f99feb043d3456f107429d6e5319258

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libiconv/libiconv.hash
package/libiconv/libiconv.mk

index 83de76f4d777f12fc6f01dade6dc4fdd700820bd..440daee51e7a814555bcddcc2121934c9c286712 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated after checking pgp signature
-sha256 72b24ded17d687193c3366d0ebe7cde1e6b18f0df8c55438ac95be39e8a30613        libiconv-1.14.tar.gz
+sha256 ccf536620a45458d26ba83887a983b96827001e92a13847b45e4925cc8913178        libiconv-1.15.tar.gz
index af8f345d300ec78cdce00661626ec4f10f1d0e03..9a8133612bf9b2d1eee4a43fdb1a5e4d12538dd9 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBICONV_VERSION = 1.14
+LIBICONV_VERSION = 1.15
 LIBICONV_SITE = $(BR2_GNU_MIRROR)/libiconv
 LIBICONV_INSTALL_STAGING = YES
 LIBICONV_LICENSE = GPL-3.0+ (iconv program), LGPL-2.0+ (library)