projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b7d87dd
)
Strip libraries
author
Peter Korsgaard
<jacmet@sunsite.dk>
Tue, 15 May 2007 13:58:35 +0000
(13:58 -0000)
committer
Peter Korsgaard
<jacmet@sunsite.dk>
Tue, 15 May 2007 13:58:35 +0000
(13:58 -0000)
toolchain/gcc/gcc-uclibc-3.x.mk
patch
|
blob
|
history
diff --git
a/toolchain/gcc/gcc-uclibc-3.x.mk
b/toolchain/gcc/gcc-uclibc-3.x.mk
index defe923b12383d10f96e7b34112d61359ac0b0e5..1d20af8105bb1026b27e72a8ac5e39da92321019 100644
(file)
--- a/
toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/
toolchain/gcc/gcc-uclibc-3.x.mk
@@
-292,9
+292,11
@@
ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
# These are in /lib, so...
rm -rf $(TARGET_DIR)/usr/lib/libgcc_s*.so*
-cp -dpf $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib/libgcc_s* $(TARGET_DIR)/lib/
+ $(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libgcc_s*
endif
ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
-cp -dpf $(STAGING_DIR)/lib/libstdc++.so* $(TARGET_DIR)/lib/
+ $(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libstc++.so*
endif
ifeq ($(BR2_INSTALL_LIBGCJ),y)
-cp -dpf $(STAGING_DIR)/lib/libgcj.so* $(TARGET_DIR)/lib/