libvips: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 20:53:56 +0000 (22:53 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:28:44 +0000 (01:28 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - dropping BR2_PACKAGE_GETTEXT selection. We adjust the comment
   explaining the BR2_USE_WCHAR dependency, since gettext is no longer
   the reason for this dependency.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libvips/Config.in
package/libvips/libvips.mk

index 87ada513d64b89bfb873606aa0d8e98b451cdfd9..e16e5277c04a425bc25e6dbbd3637c2419a001cc 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_LIBVIPS
        bool "libvips"
-       depends on BR2_USE_WCHAR # gettext, libglib2
+       depends on BR2_USE_WCHAR # libglib2
        depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
        depends on BR2_USE_MMU # fork()
        # C++ support is required to build libvips
@@ -8,7 +8,6 @@ config BR2_PACKAGE_LIBVIPS
        depends on BR2_INSTALL_LIBSTDCPP
        select BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_LIBXML2
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          libvips is a 2D image processing library. Compared to
          similar libraries, libvips runs quickly and uses little
index 974a4bec32810e7cc1b86f4f05964f4f9c13bf35..8078e046d13092383aab039961c7a9f333e49467 100644 (file)
@@ -41,7 +41,7 @@ LIBVIPS_CONF_OPTS = \
 LIBVIPS_INSTALL_STAGING = YES
 LIBVIPS_DEPENDENCIES = \
        host-pkgconf libglib2 \
-       libxml2 $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
+       libxml2 $(TARGET_NLS_DEPENDENCIES)
 
 # --disable-cxx is broken upstream
 # https://github.com/jcupitt/libvips/issues/231