imx-vpu: bump to version 5.4.33
authorAndrew Webster <awebster@arcx.com>
Fri, 10 Jun 2016 18:12:14 +0000 (14:12 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 15 Jun 2016 20:48:40 +0000 (22:48 +0200)
Changelog:
VPU firmware has been changed to the format of Linux codec driver firmware.
Change VPU library to adapt to firmware format change.

This patch is based on the Yocto equivalent:
https://github.com/Freescale/meta-fsl-arm/commit/f5e1056

Implicitly tested through gstreamer as the plugins rely on it:
 # gst-launch-0.10 playbin uri=file:///root/tears_of_steel_1080p.webm
 # gst-launch-1.0 playbin uri=file:///root/tears_of_steel_1080p.webm
 # gst-launch-1.0 filesrc location=/root/tears_of_steel_1080p.webm ! \
   matroskademux ! imxvpudec ! imxipuvideosink

Signed-off-by: Andrew Webster <awebster@arcx.com>
Reviewed-by: Gary Bisson <gary.bisson@boundarydevices.com>
Tested-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/freescale-imx/imx-vpu/imx-vpu.hash
package/freescale-imx/imx-vpu/imx-vpu.mk

index c828c2b09b7937dd6bfdd3ccd6d9763cc7c983e2..67ebaf23140e813899db651a4463dc3a355412cd 100644 (file)
@@ -1,2 +1,2 @@
 # Locally computed
-sha256 f11b91dcdb84bfefd3c88f10a9c1c1bc3420e4bbaadc38b9280fb52f7769eca8  imx-vpu-5.4.32.bin
+sha256 2e670ef2337a5dbe6c32fa07128ad9aad32afdbf472c23d44133245ec6a66d46  imx-vpu-5.4.33.bin
index 949fefa4e24e6e819d2ba20d2cbe8d101dbf771a..09ff5a80a6e06136c859bdc5606881f74f1e37e2 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-IMX_VPU_VERSION = 5.4.32
+IMX_VPU_VERSION = 5.4.33
 IMX_VPU_SITE = $(FREESCALE_IMX_SITE)
 IMX_VPU_SOURCE = imx-vpu-$(IMX_VPU_VERSION).bin
 
@@ -16,7 +16,7 @@ IMX_VPU_MAKE_ENV = \
        CROSS_COMPILE="$(TARGET_CROSS)" \
        PLATFORM=$(BR2_PACKAGE_FREESCALE_IMX_PLATFORM)
 
-IMX_VPU_LICENSE = Freescale Semiconductor Software License Agreement
+IMX_VPU_LICENSE = NXP Semiconductor Software License Agreement
 IMX_VPU_LICENSE_FILES = EULA COPYING
 IMX_VPU_REDISTRIBUTE = NO