toolchain-external: restrict Musl external toolchain to Microblaze BE
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 30 May 2014 20:24:39 +0000 (22:24 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 30 May 2014 21:27:16 +0000 (23:27 +0200)
As reported by William Welch <bvwelch@gmail.com>, the Musl external
toolchain provided by the musl-cross project is only Microblaze
big-endian. In fact, Musl seems to only support the big endian variant
of the Microblaze architecture, with the microblaze-* tuple.

This commit makes sure the Musl pre-built external toolchain provided
by musl-cross can only be selected for a big-endian Microblaze
configuration.

Reported-by: William Welch <bvwelch@gmail.com>
Cc: William Welch <bvwelch@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/toolchain-external.mk

index 857f26dad1d44c0c52f9ab54a3cf09b2a590ec83..f4a5ccf653380ad12c4c5f85b18f1189ead5c9b5 100644 (file)
@@ -871,7 +871,7 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_13_12
 config BR2_TOOLCHAIN_EXTERNAL_MUSL_CROSS
        bool "Musl toolchain"
        depends on (BR2_arm && BR2_ARM_EABI) || (BR2_armeb && BR2_ARM_EABI) || \
-               (BR2_i386 && !BR2_x86_i386) || BR2_microblaze || BR2_mips || \
+               (BR2_i386 && !BR2_x86_i386) || BR2_microblazebe || BR2_mips || \
                BR2_mipsel || (BR2_powerpc && BR2_powerpc_CLASSIC) || BR2_x86_64
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
        select BR2_TOOLCHAIN_EXTERNAL_MUSL
@@ -977,7 +977,7 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
        default "arm-linux-musleabi"     if BR2_TOOLCHAIN_EXTERNAL_MUSL_CROSS && BR2_arm
        default "armeb-linux-musleabi"   if BR2_TOOLCHAIN_EXTERNAL_MUSL_CROSS && BR2_armeb
        default "i486-linux-musl"        if BR2_TOOLCHAIN_EXTERNAL_MUSL_CROSS && BR2_i386
-       default "microblaze-linux-musl"  if BR2_TOOLCHAIN_EXTERNAL_MUSL_CROSS && BR2_microblaze
+       default "microblaze-linux-musl"  if BR2_TOOLCHAIN_EXTERNAL_MUSL_CROSS && BR2_microblazebe
        default "mips-linux-musl"        if BR2_TOOLCHAIN_EXTERNAL_MUSL_CROSS && (BR2_mips && !BR2_SOFT_FLOAT)
        default "mips-sf-linux-musl"     if BR2_TOOLCHAIN_EXTERNAL_MUSL_CROSS && (BR2_mips && BR2_SOFT_FLOAT)
        default "mipsel-linux-musl"      if BR2_TOOLCHAIN_EXTERNAL_MUSL_CROSS && (BR2_mipsel && !BR2_SOFT_FLOAT)
index 34520bebef1d573c37f83247dc06818ee32eff57..c73cc4ae4d26993821687d5b694dea03df4ef12e 100644 (file)
@@ -378,7 +378,7 @@ else ifeq ($(BR2_armeb),y)
 TOOLCHAIN_EXTERNAL_SOURCE = crossx86-armeb-linux-musleabi-1.0.0.tar.xz
 else ifeq ($(BR2_i386),y)
 TOOLCHAIN_EXTERNAL_SOURCE = crossx86-i486-linux-musl-1.0.0.tar.xz
-else ifeq ($(BR2_microblaze),y)
+else ifeq ($(BR2_microblazebe),y)
 TOOLCHAIN_EXTERNAL_SOURCE = crossx86-microblaze-linux-musl-1.0.0.tar.xz
 else ifeq ($(BR2_mips),y)
 ifeq ($(BR2_SOFT_FLOAT),y)