boot/barebox: use the generic help rules
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 4 Jun 2016 16:30:53 +0000 (18:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 7 Jun 2016 20:12:08 +0000 (22:12 +0200)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
[Thomas: don't use the helper.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile
boot/barebox/barebox/barebox.mk

index f007db2f299c899d1933d34be0da19dd68bb343e..3f5c3d3b2f13737ec65c9cc15c65bcf59f6e3fe2 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -941,10 +941,6 @@ help:
                @echo $(sep) \
                @echo '$($(p)_NAME):' $(sep) \
                $($(p)_HELP_CMDS)$(sep))
-ifeq ($(BR2_TARGET_BAREBOX),y)
-       @echo '  barebox-menuconfig     - Run barebox menuconfig'
-       @echo '  barebox-savedefconfig  - Run barebox savedefconfig'
-endif
        @echo
        @echo 'Documentation:'
        @echo '  manual                 - build manual in all formats'
index 6a5a80de34e419b98a440ed81cb7994b2d269f99..39afb0fccb0b5df23c4b24c6781c7a79234714f1 100644 (file)
@@ -4,5 +4,10 @@
 #
 ################################################################################
 
+define BAREBOX_HELP_CMDS
+       @echo '  barebox-menuconfig     - Run barebox menuconfig'
+       @echo '  barebox-savedefconfig  - Run barebox savedefconfig'
+endef
+
 # Instantiate the barebox package
 $(eval $(barebox-package))