package/kf5/kf5-extra-cmake-modules: new package
authorPierre Ducroquet <pinaraf@pinaraf.info>
Thu, 15 Feb 2018 20:48:12 +0000 (21:48 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 30 Jun 2018 22:04:14 +0000 (00:04 +0200)
kf5-extra-cmake-modules contains several additional CMake modules used
by the other KF5 packages. It does not install anything on the target
and contain only CMake files for the host.

Signed-off-by: Pierre Ducroquet <pinaraf@pinaraf.info>
[Thomas:
 - update to version 5.47
 - add hash for license file]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/kf5/Config.in
package/kf5/kf5-extra-cmake-modules/Config.in [new file with mode: 0644]
package/kf5/kf5-extra-cmake-modules/kf5-extra-cmake-modules.hash [new file with mode: 0644]
package/kf5/kf5-extra-cmake-modules/kf5-extra-cmake-modules.mk [new file with mode: 0644]

index cbc3d0b70d8741fc867e84e862a85777d57ede03..1db0fbfe513c296937dcf1defdd68a393bf6fd6d 100644 (file)
@@ -7,4 +7,5 @@ menuconfig BR2_PACKAGE_KF5
          allow to select which modules should be built.
 
 if BR2_PACKAGE_KF5
+source "package/kf5/kf5-extra-cmake-modules/Config.in"
 endif
diff --git a/package/kf5/kf5-extra-cmake-modules/Config.in b/package/kf5/kf5-extra-cmake-modules/Config.in
new file mode 100644 (file)
index 0000000..7cb1036
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_KF5_EXTRA_CMAKE_MODULES
+       bool "kf5-extra-cmake-modules"
+       help
+         KF5 is a set of Qt framework addons, extending Qt in various
+         ways, not only restricted in helping integration in KDE.
+
+         This package corresponds to the extra CMake modules,
+         required for most KF5 libraries.
+
+         https://api.kde.org/frameworks/extra-cmake-modules/html/index.html
diff --git a/package/kf5/kf5-extra-cmake-modules/kf5-extra-cmake-modules.hash b/package/kf5/kf5-extra-cmake-modules/kf5-extra-cmake-modules.hash
new file mode 100644 (file)
index 0000000..733e267
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 976d8bd15a0b929376bfaef34602a0fb9614229851c46fac3c4b28938f682195 extra-cmake-modules-5.47.0.tar.xz
+sha256 46cde7dc11e64c78d650b4851b88f6704b4665ff60f22a1caf68ceb15e217e5b COPYING-CMAKE-SCRIPTS
diff --git a/package/kf5/kf5-extra-cmake-modules/kf5-extra-cmake-modules.mk b/package/kf5/kf5-extra-cmake-modules/kf5-extra-cmake-modules.mk
new file mode 100644 (file)
index 0000000..7b96e1f
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# kf5-extra-cmake-modules
+#
+################################################################################
+
+KF5_EXTRA_CMAKE_MODULES_VERSION = $(KF5_VERSION)
+KF5_EXTRA_CMAKE_MODULES_SITE = $(KF5_SITE)
+KF5_EXTRA_CMAKE_MODULES_SOURCE = extra-cmake-modules-$(KF5_EXTRA_CMAKE_MODULES_VERSION).tar.xz
+KF5_EXTRA_CMAKE_MODULES_LICENSE = BSD-3-Clause
+KF5_EXTRA_CMAKE_MODULES_LICENSE_FILE = COPYING-CMAKE-SCRIPTS
+
+KF5_EXTRA_CMAKE_MODULES_DEPENDENCIES = host-pkgconf
+KF5_EXTRA_CMAKE_MODULES_INSTALL_STAGING = YES
+KF5_EXTRA_CMAKE_MODULES_INSTALL_TARGET = NO
+
+$(eval $(cmake-package))