policycoreutils: bump to version 2.8
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 11 Oct 2018 19:37:05 +0000 (21:37 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 11 Oct 2018 20:02:33 +0000 (22:02 +0200)
Update first and second patch

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/policycoreutils/0001-Add-DESTDIR-to-all-paths-that-use-an-absolute-path.patch
package/policycoreutils/0002-Add-PREFIX-to-host-paths.patch
package/policycoreutils/policycoreutils.hash
package/policycoreutils/policycoreutils.mk

index 3c0ddcc54b384c2b63cfcd05999aa7f5e5689cc5..4cfe969a40c8c4b7743b86466235f3b04e34d410 100644 (file)
@@ -13,6 +13,8 @@ accomodate version 2.5
 Signed-off-by: Clayton Shotwell <clayton.shotwell@rockwellcollins.com>
 Signed-off-by: Niranjan Reddy <niranjan.reddy@rockwellcollins.com>
 Signed-off-by: Adam Duskett <AdamDuskett@outlook.com>
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Update for 2.8]
 ---
  setfiles/Makefile | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
@@ -22,11 +24,11 @@ index c08e2dd..36c0638 100644
 --- a/setfiles/Makefile
 +++ b/setfiles/Makefile
 @@ -3,7 +3,7 @@ PREFIX ?= $(DESTDIR)/usr
- SBINDIR ?= $(DESTDIR)/sbin
+ PREFIX ?= /usr
+ SBINDIR ?= /sbin
  MANDIR = $(PREFIX)/share/man
- LIBDIR ?= $(PREFIX)/lib
 -AUDITH ?= $(shell test -f /usr/include/libaudit.h && echo y)
-+AUDITH ?= $(shell test -f $(DESTDIR)/include/libaudit.h && echo y)
++AUDITH ?= $(shell test -f $(DESTDIR)$(PREFIX)/include/libaudit.h && echo y)
  
  ABORT_ON_ERRORS=$(shell grep "^\#define ABORT_ON_ERRORS" setfiles.c | awk -S '{ print $$3 }')
  
index 32d2ae92e60b9f5a85320bd000bfdbea3d83aaca..0b530441807106adb4cb96f2f3c8048c269e2e7a 100644 (file)
@@ -11,25 +11,14 @@ Updated to work with version 2.5
 Signed-off-by: Clayton Shotwell <clayton.shotwell@rockwellcollins.com>
 Signed-off-by: Niranjan Reddy <niranjan.reddy@rockwellcollins.com>
 Signed-off-by: Adam Duskett <AdamDuskett@outlook.com>
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Update for 2.8]
 ---
  load_policy/Makefile | 2 +-
  newrole/Makefile     | 6 +++---
  run_init/Makefile    | 6 +++---
  3 files changed, 7 insertions(+), 7 deletions(-)
 
-diff --git a/load_policy/Makefile b/load_policy/Makefile
-index b85833c..6a45f31 100644
---- a/load_policy/Makefile
-+++ b/load_policy/Makefile
-@@ -2,7 +2,7 @@
- PREFIX ?= $(DESTDIR)/usr
- SBINDIR ?= $(DESTDIR)/sbin
- MANDIR ?= $(PREFIX)/share/man
--LOCALEDIR ?= /usr/share/locale
-+LOCALEDIR ?= $(PREFIX)/share/locale
- CFLAGS ?= -Werror -Wall -W
- override CFLAGS += $(LDFLAGS) -DUSE_NLS -DLOCALEDIR="\"$(LOCALEDIR)\"" -DPACKAGE="\"policycoreutils\""
 diff --git a/newrole/Makefile b/newrole/Makefile
 index 196af92..896708f 100644
 --- a/newrole/Makefile
@@ -37,13 +26,12 @@ index 196af92..896708f 100644
 @@ -3,9 +3,9 @@ PREFIX ?= $(DESTDIR)/usr
  BINDIR ?= $(PREFIX)/bin
  MANDIR ?= $(PREFIX)/share/man
- ETCDIR ?= $(DESTDIR)/etc
--LOCALEDIR = /usr/share/locale
+ ETCDIR ?= /etc
+ LOCALEDIR = $(DESTDIR)$(PREFIX)/share/locale
 -PAMH ?= $(shell test -f /usr/include/security/pam_appl.h && echo y)
 -AUDITH ?= $(shell test -f /usr/include/libaudit.h && echo y)
-+LOCALEDIR = $(PREFIX)/share/locale
-+PAMH ?= $(shell test -f $(PREFIX)/include/security/pam_appl.h && echo y)
-+AUDITH ?= $(shell test -f $(PREFIX)/include/libaudit.h && echo y)
++PAMH ?= $(shell test -f $(DESTDIR)$(PREFIX)/include/security/pam_appl.h && echo y)
++AUDITH ?= $(shell test -f $(DESTDIR)$(PREFIX)/include/libaudit.h && echo y)
  # Enable capabilities to permit newrole to generate audit records.
  # This will make newrole a setuid root program.
  # The capabilities used are: CAP_AUDIT_WRITE.
@@ -54,13 +42,12 @@ index 921f0b0..e1566fc 100644
 @@ -4,9 +4,9 @@ PREFIX ?= $(DESTDIR)/usr
  SBINDIR ?= $(PREFIX)/sbin
  MANDIR ?= $(PREFIX)/share/man
- ETCDIR ?= $(DESTDIR)/etc
--LOCALEDIR ?= /usr/share/locale
+ ETCDIR ?= /etc
+ LOCALEDIR ?= $(DESTDIR)$(PREFIX)/share/locale
 -PAMH ?= $(shell test -f /usr/include/security/pam_appl.h && echo y)
 -AUDITH ?= $(shell test -f /usr/include/libaudit.h && echo y)
-+LOCALEDIR ?= $(PREFIX)/share/locale
-+PAMH ?= $(shell test -f $(PREFIX)/include/security/pam_appl.h && echo y)
-+AUDITH ?= $(shell test -f $(PREFIX)/include/libaudit.h && echo y)
++PAMH ?= $(shell test -f $(DESTDIR)$(PREFIX)/include/security/pam_appl.h && echo y)
++AUDITH ?= $(shell test -f $(DESTDIR)$(PREFIX)/include/libaudit.h && echo y)
  
  CFLAGS ?= -Werror -Wall -W
  override CFLAGS += -DUSE_NLS -DLOCALEDIR="\"$(LOCALEDIR)\"" -DPACKAGE="\"policycoreutils\""
index 241905ca22e2fb247735aba096511b1fd24dd1b3..b6367b4bf456fbb2cd268d52954329f8e5e01480 100644 (file)
@@ -1,3 +1,3 @@
 # https://github.com/SELinuxProject/selinux/wiki/Releases
-sha256 0a1b8a4a323b854981c6755ff025fe98a0f1cff307f109abb260f0490f13e4f4 policycoreutils-2.7.tar.gz
+sha256 986553a235f27bee7ad7c2b7c35ea51eb2ee68e2cf03b661b1585de101bc1099 policycoreutils-2.8.tar.gz
 sha256 204d8eff92f95aac4df6c8122bc1505f468f3a901e5a4cc08940e0ede1938994 COPYING
index 21c5470cec5ded6d19e2af26e388352556931bfc..abd70e16c80aeebc0f48300e4cb7ceb0fe10530f 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-POLICYCOREUTILS_VERSION = 2.7
-POLICYCOREUTILS_SITE = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804
+POLICYCOREUTILS_VERSION = 2.8
+POLICYCOREUTILS_SITE = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524
 POLICYCOREUTILS_LICENSE = GPL-2.0
 POLICYCOREUTILS_LICENSE_FILES = COPYING