package/gdbm: add optional support for readline
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 3 Jun 2017 17:34:59 +0000 (19:34 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Jun 2017 07:51:34 +0000 (09:51 +0200)
readline support was added in version 1.13:

http://puszcza.gnu.org.ua/forum/forum.php?forum_id=1145
"The gdbmtool utility now offers the usual line-editing facilities
 (if the package has been compiled with GNU Readline."

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gdbm/gdbm.mk

index 290e8410ef513bf3d9f7d27c2699a711fbe8c998..4e3ed76e8171c0287a737817b82c80fb4312e79c 100644 (file)
@@ -14,4 +14,11 @@ ifeq ($(BR2_PACKAGE_GETTEXT),y)
 GDBM_DEPENDENCIES += gettext
 endif
 
+ifeq ($(BR2_PACKAGE_READLINE),y)
+GDBM_CONF_OPTS += --with-readline
+GDBM_DEPENDENCIES += readline
+else
+GDBM_CONF_OPTS += --without-readline
+endif
+
 $(eval $(autotools-package))