package/python-sip: remove qt4 support
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 6 Feb 2019 14:10:45 +0000 (15:10 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 6 Feb 2019 14:37:39 +0000 (15:37 +0100)
python-pyqt has been removed and qt4 support is about to be dropped, so
remove the support from python-sip as well.

The comments and dependencies are not how we normally do things: the
dependency on Qt5 is obvious for a package which is essentially python
bindings for Qt5, and the other dependencies are implied by Qt5. So
remove all that and limit to a single dependency on Qt5.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
[Arnout: further simplify dependencies and comments]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/python-sip/Config.in
package/python-sip/python-sip.mk

index 1f8961d0dfb76bc2e1e6e47264807841ea6b796b..8a43b8b17f4d1dc742092bad40c36b61a202ad51 100644 (file)
@@ -1,18 +1,6 @@
-comment "python-sip needs a toolchain w/ C++, threads"
-       depends on BR2_USE_MMU
-       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
-
-comment "python-sip needs qt or qt5"
-       depends on BR2_USE_MMU
-       depends on BR2_INSTALL_LIBSTDCPP && BR2_TOOLCHAIN_HAS_THREADS
-       depends on !BR2_PACKAGE_QT && !BR2_PACKAGE_QT5
-
 config BR2_PACKAGE_PYTHON_SIP
        bool "python-sip"
-       depends on BR2_INSTALL_LIBSTDCPP # qt
-       depends on BR2_TOOLCHAIN_HAS_THREADS # qt
-       depends on BR2_USE_MMU # qt
-       depends on BR2_PACKAGE_QT || BR2_PACKAGE_QT5
+       depends on BR2_PACKAGE_QT5
        help
          SIP is a tool that makes it very easy to create Python
          bindings for C and C++ libraries. It was originally
index 76d7d041872a38201ca6416bb77e2dc4122c17a0..69019f5f191e9ade003c8eabfbead429be5da875 100644 (file)
@@ -10,11 +10,7 @@ PYTHON_SIP_SITE = http://downloads.sourceforge.net/project/pyqt/sip/sip-$(PYTHON
 PYTHON_SIP_LICENSE = SIP license or GPL-2.0 or GPL-3.0
 PYTHON_SIP_LICENSE_FILES = LICENSE LICENSE-GPL2 LICENSE-GPL3
 
-ifeq ($(BR2_PACKAGE_QT5),y)
 PYTHON_SIP_DEPENDENCIES = qt5base
-else
-PYTHON_SIP_DEPENDENCIES = qt
-endif
 
 ifeq ($(BR2_PACKAGE_PYTHON),y)
 PYTHON_SIP_DEPENDENCIES += python