package/libubox: bump version to 5bc0146a
authorPeter Seiderer <ps.report@gmx.net>
Wed, 10 Feb 2021 23:16:34 +0000 (00:16 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 13 Feb 2021 22:24:19 +0000 (23:24 +0100)
- change download url to https

- update homepage url (the old one returns 404 - No projects found)

- add hash file

- delete 0001-blobmsg-fix-array-out-of-bounds-GCC-10-warning.patch
  (from upstream [1])

[1] https://git.openwrt.org/?p=project/libubox.git;a=commit;h=eb7eb6393d47a918c420f5b287946dbd6c0d5f57

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libubox/0001-blobmsg-fix-array-out-of-bounds-GCC-10-warning.patch [deleted file]
package/libubox/Config.in
package/libubox/libubox.hash [new file with mode: 0644]
package/libubox/libubox.mk

diff --git a/package/libubox/0001-blobmsg-fix-array-out-of-bounds-GCC-10-warning.patch b/package/libubox/0001-blobmsg-fix-array-out-of-bounds-GCC-10-warning.patch
deleted file mode 100644 (file)
index 09128db..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-From eb7eb6393d47a918c420f5b287946dbd6c0d5f57 Mon Sep 17 00:00:00 2001
-From: =?utf8?q?Petr=20=C5=A0tetiar?= <ynezz@true.cz>
-Date: Wed, 25 Dec 2019 10:27:59 +0100
-Subject: [PATCH] blobmsg: fix array out of bounds GCC 10 warning
-MIME-Version: 1.0
-Content-Type: text/plain; charset=utf8
-Content-Transfer-Encoding: 8bit
-
-Fixes following warning reported by GCC 10.0.0 20191203:
-
- blobmsg.c:234:2: error: 'strcpy' offset 6 from the object at 'attr' is out of the bounds of referenced subobject 'name' with type 'uint8_t[0]' {aka 'unsigned char[0]'} at offset 6 [-Werror=array-bounds]
-   234 |  strcpy((char *) hdr->name, (const char *)name);
-       |  ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-
- In file included from blobmsg.c:16:
- blobmsg.h:42:10: note: subobject 'name' declared here
-    42 |  uint8_t name[];
-       |          ^~~~
-
-Reported-by: Khem Raj <raj.khem@gmail.com>
-Signed-off-by: Petr Å tetiar <ynezz@true.cz>
-[Retrieved from:
-https://git.openwrt.org/?p=project/libubox.git;a=commit;h=eb7eb6393d47a918c420f5b287946dbd6c0d5f57]
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- blobmsg.c | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/blobmsg.c b/blobmsg.c
-index 48dba81..37821c3 100644
---- a/blobmsg.c
-+++ b/blobmsg.c
-@@ -240,7 +240,10 @@ blobmsg_new(struct blob_buf *buf, int type, const char *name, int payload_len, v
-       attr->id_len |= be32_to_cpu(BLOB_ATTR_EXTENDED);
-       hdr = blob_data(attr);
-       hdr->namelen = cpu_to_be16(namelen);
--      strcpy((char *) hdr->name, (const char *)name);
-+
-+      memcpy(hdr->name, name, namelen);
-+      hdr->name[namelen] = '\0';
-+
-       pad_end = *data = blobmsg_data(attr);
-       pad_start = (char *) &hdr->name[namelen];
-       if (pad_start < pad_end)
--- 
-2.20.1
-
index 25ef4bb89aedb86dd73043b0d3311c01463c22f6..1f0b691e13c70e9f67a0b13dce9922633fe09a0c 100644 (file)
@@ -7,7 +7,7 @@ config BR2_PACKAGE_LIBUBOX
          also be used for the same purposes in projects other
          than OpenWrt.
 
-         http://nbd.name/gitweb.cgi?p=luci2/libubox.git;a=summary
+         https://openwrt.org/docs/techref/libubox
 
 comment "libubox needs a toolchain w/ dynamic library"
        depends on BR2_STATIC_LIBS
diff --git a/package/libubox/libubox.hash b/package/libubox/libubox.hash
new file mode 100644 (file)
index 0000000..fd4c5a4
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256  e383caf80a241e9711ab0c58a5e8f4d16479693be1e44ffb6cc716a185e7e303  libubox-5bc0146a1d6474d339c4ade9a227f32cc27a8b93-br1.tar.gz
index d3e3b709dc01bc3ad7f9f88cacff2281efefa1ca..46266591586cc232217e11806050729ca66b5c17 100644 (file)
@@ -4,8 +4,9 @@
 #
 ################################################################################
 
-LIBUBOX_VERSION = 723730214732862de7e892bae2f7a7889e66bf1b
-LIBUBOX_SITE = git://git.openwrt.org/project/libubox.git
+LIBUBOX_VERSION = 5bc0146a1d6474d339c4ade9a227f32cc27a8b93
+LIBUBOX_SITE = https://git.openwrt.org/project/libubox.git
+LIBUBOX_SITE_METHOD = git
 LIBUBOX_LICENSE = ISC, BSD-3-Clause
 LIBUBOX_INSTALL_STAGING = YES
 LIBUBOX_DEPENDENCIES = $(if $(BR2_PACKAGE_JSON_C),json-c)