Makefile: add pkg-stats target
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 5 Nov 2020 16:30:22 +0000 (17:30 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 11 Nov 2020 11:07:51 +0000 (12:07 +0100)
Now that pkg-stats is not just a maintainer-oriented tool, but a tool
generally useful to users, introduce a make target to run
pkg-stats. Of course, it is run with the newly introduced -c option,
which produces a pkg-stats output for just the selection of packages
of the currently defined configuration.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile

index f9e9cfa9684aa6de48cbc9a381cc86dcd4324e70..fa648d5d54e3fbfad757e45d7c5753c0c734166b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -937,6 +937,14 @@ show-info:
                ) \
        )
 
+.PHONY: pkg-stats
+pkg-stats:
+       @cd "$(CONFIG_DIR)" ; \
+       $(TOPDIR)/support/scripts/pkg-stats -c \
+               --json $(O)/pkg-stats.json \
+               --html $(O)/pkg-stats.html \
+               --nvd-path $(DL_DIR)/buildroot-nvd
+
 else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
 
 # Some subdirectories are also package names. To avoid that "make linux"
@@ -1154,6 +1162,7 @@ help:
        @echo '  external-deps          - list external packages used'
        @echo '  legal-info             - generate info about license compliance'
        @echo '  show-info              - generate info about packages, as a JSON blurb'
+       @echo '  pkg-stats              - generate info about packages as JSON and HTML'
        @echo '  printvars              - dump internal variables selected with VARS=...'
        @echo
        @echo '  make V=0|1             - 0 => quiet build (default), 1 => verbose build'