package/mplayer: disable external mmx
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 10 Apr 2017 20:41:22 +0000 (22:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 12 Apr 2017 20:45:56 +0000 (22:45 +0200)
Fixes a follow-up error with this defconfig
http://autobuild.buildroot.net/results/642/6422adeef19ec547c7bc3f8ad3b0d51702015240/
which occurs after disabling inline mmx with the previous patch:

This is the error message:

fmpeg/libavcodec/libavcodec.a(apedec.o): In function `ape_decode_frame':
apedec.c:(.text+0x1df5): undefined reference to `avpriv_emms_yasm'
ffmpeg/libavcodec/libavcodec.a(asvdec.o): In function `decode_frame':
asvdec.c:(.text+0x77c): undefined reference to `avpriv_emms_yasm'
ffmpeg/libavcodec/libavcodec.a(bink.o): In function `decode_frame':
bink.c:(.text+0x2809): undefined reference to `avpriv_emms_yasm'
ffmpeg/libavcodec/libavcodec.a(dvdec.o): In function `dvvideo_decode_frame':
dvdec.c:(.text+0x575): undefined reference to `avpriv_emms_yasm'
ffmpeg/libavcodec/libavcodec.a(ffv1dec.o): In function `decode_slice':
ffv1dec.c:(.text+0x3110): undefined reference to `avpriv_emms_yasm'
ffmpeg/libavcodec/libavcodec.a(h264.o):h264.c:(.text+0xea8): more undefined references to `avpriv_emms_yasm' follow

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mplayer/mplayer.mk

index 166394cac0387c384bd472a0913edd3bdaed3eb7..88f2fb4efa8f70a1d8eaa99f1dc7f242fbd9f514 100644 (file)
@@ -290,6 +290,8 @@ define MPLAYER_DISABLE_INLINE_ASM
                $(@D)/config.h
        $(SED) 's,#define HAVE_MMX_INLINE 1,#define HAVE_MMX_INLINE 0,g' \
                $(@D)/config.h
+       $(SED) 's,#define HAVE_MMX_EXTERNAL 1,#define HAVE_MMX_EXTERNAL 0,g' \
+               $(@D)/config.h
 endef
 
 ifeq ($(BR2_i386),y)