gmp/mpfr: fix up dependencies to stop continous rebuild with --disable-shared
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 10 Feb 2009 15:19:31 +0000 (15:19 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 10 Feb 2009 15:19:31 +0000 (15:19 -0000)
Don't list the shared objects as targets for the host compilation now that
we compile with --disable-shared.

package/gmp/gmp.mk
package/mpfr/mpfr.mk

index 00a92ef12e1034d59577bde919ed8353e40443bd..320a6422f992d13a76c99a8b8032e7fc12dbbdfb 100644 (file)
@@ -89,7 +89,7 @@ $(GMP_DIR2)/.configured: $(GMP_DIR)/.unpacked
        )
        touch $@
 
-$(GMP_HOST_DIR)/lib/libgmp$(HOST_LIBEXT) $(GMP_HOST_DIR)/lib/libgmp$(HOST_SHREXT) $(GMP_HOST_DIR)/lib/libgmp$(HOST_SHREXT).(GMP_LIBVERSION): $(GMP_DIR2)/.configured
+$(GMP_HOST_DIR)/lib/libgmp$(HOST_LIBEXT): $(GMP_DIR2)/.configured
        $(MAKE) -C $(GMP_DIR2) install
 
 host-libgmp: $(GMP_HOST_DIR)/lib/$(GMP_HOST_BINARY)
index 51b9fb5ec243c3d96e92502f6c983bdb784d1b4b..d3c04eae7203f3f882e62d19dcf816ee4c6eea8e 100644 (file)
@@ -103,7 +103,7 @@ $(MPFR_DIR2)/.configured: $(MPFR_DIR)/.unpacked $(GMP_HOST_DIR)/lib/$(GMP_HOST_B
        )
        touch $@
 
-$(MPFR_HOST_DIR)/lib/libmpfr$(HOST_LIBEXT) $(MPFR_HOST_DIR)/lib/libmpfr$(HOST_SHREXT) $(MPFR_HOST_DIR)/lib/libmpfr$(HOST_SHREXT).$(MPFR_LIBVERSION): $(MPFR_DIR2)/.configured
+$(MPFR_HOST_DIR)/lib/libmpfr$(HOST_LIBEXT): $(MPFR_DIR2)/.configured
        $(MAKE) -C $(MPFR_DIR2) install
 
 host-libmpfr: $(MPFR_HOST_DIR)/lib/$(MPFR_HOST_BINARY)