package/rcw: allow not having custom rcwi files
authorFrancois Gervais <fgervais@distech-controls.com>
Fri, 21 Feb 2020 14:40:23 +0000 (09:40 -0500)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 23 Feb 2020 21:16:19 +0000 (22:16 +0100)
A project could quite possibly have a custom rcw file
that does not rely on any custom rcw include files (rcwi).

Allow the build to succeed if this is the case.

Signed-off-by: Francois Gervais <fgervais@distech-controls.com>
[yann.morin.1998@free.fr: install includes in a separate hook]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/rcw/rcw.mk

index 36d2da61b55ee10ef2a4de3e64c4f8cf76aebb16..81e22fff93850d32413c83b46c2e2c7a5ca398e1 100644 (file)
@@ -13,6 +13,7 @@ RCW_LICENSE_FILES = LICENSE
 RCW_FILES = $(call qstrip,$(BR2_PACKAGE_HOST_RCW_CUSTOM_PATH))
 
 ifneq ($(RCW_FILES),)
+RCW_INCLUDES = $(filter-out %.rcw,$(RCW_FILES))
 # Get the name of the custom rcw file from the custom list
 RCW_PROJECT = $(notdir $(filter %.rcw,$(RCW_FILES)))
 
@@ -23,9 +24,16 @@ $(error BR2_PACKAGE_HOST_RCW_CUSTOM_PATH must have exactly one .rcw file)
 endif
 endif
 
+ifneq ($(RCW_INCLUDES),)
+define HOST_RCW_ADD_CUSTOM_RCW_INCLUDES
+       mkdir -p $(@D)/custom_board
+       cp -f $(RCW_INCLUDES) $(@D)/custom_board
+endef
+HOST_RCW_POST_PATCH_HOOKS += HOST_RCW_ADD_CUSTOM_RCW_INCLUDES
+endif
+
 define HOST_RCW_ADD_CUSTOM_RCW_FILES
        mkdir -p $(@D)/custom_board/rcw
-       cp -f $(filter-out %.rcw,$(RCW_FILES)) $(@D)/custom_board
        cp -f $(filter %.rcw,$(RCW_FILES)) $(@D)/custom_board/rcw
 endef
 HOST_RCW_POST_PATCH_HOOKS += HOST_RCW_ADD_CUSTOM_RCW_FILES