nodejs: fix build of host-nodejs
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 6 Sep 2014 17:00:54 +0000 (19:00 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 6 Sep 2014 20:17:18 +0000 (22:17 +0200)
In commit 89fae0d05daa8645ae3078746065ebed5c3c049f ("nodejs: Add
dependency on zlib"), Paul added a dependency of host-nodejs on
host-zlib. When host-zlib is built, the host variant of zlib is
installed in $(HOST_DIR)/usr/lib. However, even though
-L$(HOST_DIR)/usr/lib is passed to the LDFLAGS of host-nodejs
configure script, those LDFLAGS are not re-used at build and install
time. This is because nodejs does not use the autotools and its
configure script does not "save" the environment variables such as
LDFLAGS. This is causing build failures such as:

  http://autobuild.buildroot.org/results/802/802134ceb92d82d2d4ef6a81c67ad1c98696663a/

due to the fact that the host zlib cannot be found.

This commit fixes that by passing $(HOST_CONFIGURE_OPTS) explicitly at
both build time and install time of host-nodejs. This approach was
already used for the target variant of nodejs.

Cc: Paul Cercueil <paul@crapouillou.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/nodejs/nodejs.mk

index 8a337ed7c04a1ba7512a802f5a6153d8da9e5334..ba425bbbd52ea69bf68b88fd6de5b772a372fa1e 100644 (file)
@@ -37,11 +37,15 @@ define HOST_NODEJS_CONFIGURE_CMDS
 endef
 
 define HOST_NODEJS_BUILD_CMDS
-       $(HOST_MAKE_ENV) PYTHON=$(HOST_DIR)/usr/bin/python2 $(MAKE) -C $(@D)
+       $(HOST_MAKE_ENV) PYTHON=$(HOST_DIR)/usr/bin/python2 \
+               $(MAKE) -C $(@D) \
+               $(HOST_CONFIGURE_OPTS)
 endef
 
 define HOST_NODEJS_INSTALL_CMDS
-       $(HOST_MAKE_ENV) PYTHON=$(HOST_DIR)/usr/bin/python2 $(MAKE) -C $(@D) install
+       $(HOST_MAKE_ENV) PYTHON=$(HOST_DIR)/usr/bin/python2 \
+               $(MAKE) -C $(@D) install \
+               $(HOST_CONFIGURE_OPTS)
 endef
 
 ifeq ($(BR2_i386),y)