python-sdnotify: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Wed, 15 Jun 2016 10:09:14 +0000 (12:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 15 Jun 2016 20:18:34 +0000 (22:18 +0200)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-sdnotify/Config.in [new file with mode: 0644]
package/python-sdnotify/python-sdnotify.hash [new file with mode: 0644]
package/python-sdnotify/python-sdnotify.mk [new file with mode: 0644]

index ff08f27fb653a24a8e5e8adf337ed605e2e97e6d..753f5aaedff204122471f17d9bada7e6a2c076e4 100644 (file)
@@ -745,6 +745,7 @@ menu "External python modules"
        source "package/python-requests/Config.in"
        source "package/python-rpi-gpio/Config.in"
        source "package/python-rtslib-fb/Config.in"
+       source "package/python-sdnotify/Config.in"
        source "package/python-serial/Config.in"
        source "package/python-service-identity/Config.in"
        source "package/python-setproctitle/Config.in"
diff --git a/package/python-sdnotify/Config.in b/package/python-sdnotify/Config.in
new file mode 100644 (file)
index 0000000..bc77a06
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_SDNOTIFY
+       bool "python-sdnotify"
+       help
+         A pure Python implementation of systemd's service notification
+         protocol (sd_notify).
+
+         https://github.com/bb4242/sdnotify
diff --git a/package/python-sdnotify/python-sdnotify.hash b/package/python-sdnotify/python-sdnotify.hash
new file mode 100644 (file)
index 0000000..4339c8f
--- /dev/null
@@ -0,0 +1,4 @@
+# md5 from https://pypi.python.org/pypi/sdnotify/json
+md5    8e6a6e25560162c113fa54fc3fad98f5  sdnotify-0.3.0.tar.gz
+# sha256 calculated by scanpypi
+sha256 55fcaffb239f392ecf5b2211ef65f858b8fbbc857be8ca2b6f27b011db9c2ce6  sdnotify-0.3.0.tar.gz
diff --git a/package/python-sdnotify/python-sdnotify.mk b/package/python-sdnotify/python-sdnotify.mk
new file mode 100644 (file)
index 0000000..aeeefd7
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-sdnotify
+#
+################################################################################
+
+PYTHON_SDNOTIFY_VERSION = 0.3.0
+PYTHON_SDNOTIFY_SOURCE = sdnotify-$(PYTHON_SDNOTIFY_VERSION).tar.gz
+PYTHON_SDNOTIFY_SITE = https://pypi.python.org/packages/6f/ef/d57f930ba403b2e6440bd7ab14dbdd7ce1a1bfb5617bba62a950d04bfa34
+PYTHON_SDNOTIFY_SETUP_TYPE = distutils
+PYTHON_SDNOTIFY_LICENSE = MIT
+
+$(eval $(python-package))