usbutils: lsusb.py is for python 3.x only
authorBaruch Siach <baruch@tkos.co.il>
Tue, 29 May 2018 16:12:14 +0000 (19:12 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 29 May 2018 19:17:25 +0000 (21:17 +0200)
usbutils version 010 converted the lsusb.py script to Python 3. Keep the
lsusb.py script on target only when Python 3.x is enabled.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/usbutils/usbutils.mk

index 98b7894ae7746130d4692a9372c4b21ba5c51ec3..43322e4a654b0f628d91d76c53f9cad58dabe1b9 100644 (file)
@@ -16,8 +16,8 @@ ifeq ($(BR2_PACKAGE_BUSYBOX),y)
 USBUTILS_DEPENDENCIES += busybox
 endif
 
-# Nice lsusb.py script only if there's python
-ifeq ($(BR2_PACKAGE_PYTHON),)
+# Nice lsusb.py script only if there's python 3.x
+ifeq ($(BR2_PACKAGE_PYTHON3),)
 define USBUTILS_REMOVE_PYTHON
        rm -f $(TARGET_DIR)/usr/bin/lsusb.py
 endef