linux: Force CONFIG_NET=y when using mdev+devtempfs for /dev management
authorTitouan Christophe <titouan.christophe@railnova.eu>
Thu, 20 Jun 2019 16:59:44 +0000 (18:59 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 31 Jul 2019 06:20:11 +0000 (08:20 +0200)
Since mdev was switched to the daemon mode introduced in Busybox 1.31.0,
it requires CONFIG_NET to be enabled in the kernel such that the mdev
daemon can listen to netlink events.

Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
linux/linux.mk

index a1378345c351ae48d5356e21ba25dbdca65122a8..29d2f0ee69682e9d7494f6555e8a7cac15941f18 100644 (file)
@@ -335,6 +335,8 @@ define LINUX_KCONFIG_FIXUP_CMDS
                $(call KCONFIG_ENABLE_OPT,CONFIG_DEVTMPFS_MOUNT,$(@D)/.config))
        $(if $(BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_EUDEV),
                $(call KCONFIG_ENABLE_OPT,CONFIG_INOTIFY_USER,$(@D)/.config))
+       $(if $(BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV),
+               $(call KCONFIG_ENABLE_OPT,CONFIG_NET,$(@D)/.config))
        $(if $(BR2_PACKAGE_AUDIT),
                $(call KCONFIG_ENABLE_OPT,CONFIG_NET,$(@D)/.config)
                $(call KCONFIG_ENABLE_OPT,CONFIG_AUDIT,$(@D)/.config))