As noted by Joakim Tjernlund, we should force ln to overwrite
authorEric Andersen <andersen@codepoet.org>
Tue, 20 Jan 2004 17:51:43 +0000 (17:51 -0000)
committerEric Andersen <andersen@codepoet.org>
Tue, 20 Jan 2004 17:51:43 +0000 (17:51 -0000)
existing symlinks.

make/gcc-uclibc-2.95.mk
make/gcc-uclibc-3.3.mk

index c9f1b92da33ef6ffa89d93abf2fd52aa2cc68383..5a20512929f068bedcbc552ef2f333ce2c2a9fb8 100644 (file)
@@ -188,10 +188,10 @@ $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
        # Set up the symlinks to enable lying about target name.
        set -e; \
        (cd $(STAGING_DIR); \
-               ln -s $(REAL_GNU_TARGET_NAME) $(GNU_TARGET_NAME); \
+               ln -sf $(REAL_GNU_TARGET_NAME) $(GNU_TARGET_NAME); \
                cd bin; \
                for app in $(REAL_GNU_TARGET_NAME)-* ; do \
-                       ln -s $${app} \
+                       ln -sf $${app} \
                        $(GNU_TARGET_NAME)$${app##$(REAL_GNU_TARGET_NAME)}; \
                done; \
        );
index 532373a198d928620fbaf2b9f97a09f53ee9d9f8..172f112b46b5f1338a14a4ee7559c07f9b3974f3 100644 (file)
@@ -153,10 +153,10 @@ $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
        # Set up the symlinks to enable lying about target name.
        set -e; \
        (cd $(STAGING_DIR); \
-               ln -s $(REAL_GNU_TARGET_NAME) $(GNU_TARGET_NAME); \
+               ln -sf $(REAL_GNU_TARGET_NAME) $(GNU_TARGET_NAME); \
                cd bin; \
                for app in $(REAL_GNU_TARGET_NAME)-* ; do \
-                       ln -s $${app} \
+                       ln -sf $${app} \
                        $(GNU_TARGET_NAME)$${app##$(REAL_GNU_TARGET_NAME)}; \
                done; \
        );