package/linux-firmware: add option for Microchip VSC85xx networking PHYs
authorAntoine Tenart <antoine.tenart@bootlin.com>
Tue, 3 Mar 2020 10:13:37 +0000 (11:13 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 5 Mar 2020 17:24:58 +0000 (18:24 +0100)
This patch adds an option to support installing firmware files for the
Microchip/Microsemi VSC85xx networking PHY family.

There is a mismatch between Linux and Linux-firmware on the name of the
PHY (Microchip vs Microsemi), due to the acquisition of Microsemi by
Microchip. We chose here the name in Linux-firmware, but mentioned the
other one in the Kconfig help of the option.

Signed-off-by: Antoine Tenart <antoine.tenart@bootlin.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/linux-firmware/Config.in
package/linux-firmware/linux-firmware.hash
package/linux-firmware/linux-firmware.mk

index 9d142d2c5415d7777d1ebc2e48d57a6761bd1498..4768ea6772727158ce8cfd04d107f5f3dfe9219b 100644 (file)
@@ -367,6 +367,13 @@ config BR2_PACKAGE_LINUX_FIRMWARE_INTEL_E100
          Firmware files for Intel 825xx handled by driver e100
          (e100)
 
+config BR2_PACKAGE_LINUX_FIRMWARE_MICROCHIP_VSC85XX_PHY
+       bool "Microchip VSC85xx PHYs"
+       help
+         Firmware files for Microchip/Microsemi VSC85xx networking
+         PHYs (VSC8504, VSC8552, VSC8572, VSC8574, VSC856X, VSC8575,
+         VSC8582 and VSC8584)
+
 config BR2_PACKAGE_LINUX_FIRMWARE_QLOGIC_4X
        bool "QLogic FastLinQ 4xxxx"
        help
index 573c33cbc91b0c211a10cafbad2d5c3d26433140..3878d92881708f45d158f4c8d19c7eb910f632ab 100644 (file)
@@ -12,6 +12,7 @@ sha256 60fbc9cccb455e1a3306c97db942d6f24fa93664be61d54c497637e6d0e2ae83 LICENCE.
 sha256 5181b0b51efc79d5acb2c9bb92042878fdbad97a92114d4ab5e32e2b5b52fce4 LICENCE.ibt_firmware
 sha256 0e0c11073ba3c832097da38e0905da36b8a3526f219407977b13b71c6675be7d LICENCE.it913x
 sha256 e295020afd7597dc1b3bbe50a84a7e432d9cb92bc053c1c5e657b50d2517627b LICENCE.iwlwifi_firmware
+sha256 0fc67bd715b3395f3f2af464781910e9e69c4ba23da304352229b42dc9e986c3 LICENCE.microchip
 sha256 2051d5bf0755a0668f8c3d9a0d1c41d4b8cc411aba70f720fda71ae9e3b4d25c LICENCE.qat_firmware
 sha256 4071a11d878dbc0ac6d9e71203d03b151638f9d7a8bc47a54c3cb964100d5822 LICENCE.qla2xxx
 sha256 d7bec70668ddd4aae8fb4aa32870e54b49fcdb0b9b007aa9f54b53a1ac7461bd LICENCE.ralink-firmware.txt
index 6d3cec1a48ebce814585cb8882d980828a4c9673..aec76d54b98b59447b37ea83569a91bcefc47f0c 100644 (file)
@@ -444,6 +444,11 @@ LINUX_FIRMWARE_FILES += e100/*.bin
 LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.e100
 endif
 
+ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_MICROCHIP_VSC85XX_PHY),y)
+LINUX_FIRMWARE_FILES += microchip/mscc_vsc85*.bin
+LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.microchip
+endif
+
 ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_QLOGIC_4X),y)
 LINUX_FIRMWARE_FILES += \
        qed/qed_init_values_zipped-*.bin