graph-depends: fix when $(O) is a relative path
authorArnout Vandecappelle <arnout@mind.be>
Wed, 18 Jun 2014 22:10:24 +0000 (00:10 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 29 Jun 2014 08:52:19 +0000 (10:52 +0200)
The graph-depends commands cd into the CONFIG_DIR and run the script
from there. However, this means that when $(O) is a relative path, it
will no longer be correct.  Therefore, use $(BASE_DIR) instead of $(O).

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index 4fe370abf391d206d6e3d9a4072e7e29fa6b0ef4..9c54992c8f242e30122b197cad7b87c092a50258 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -681,8 +681,8 @@ graph-depends: graph-depends-requirements
        @$(INSTALL) -d $(O)/graphs
        @cd "$(CONFIG_DIR)"; \
        $(TOPDIR)/support/scripts/graph-depends $(BR2_GRAPH_DEPS_OPTS) \
-       |tee $(O)/graphs/$(@).dot \
-       |dot $(BR2_GRAPH_DOT_OPTS) -T$(BR_GRAPH_OUT) -o $(O)/graphs/$(@).$(BR_GRAPH_OUT)
+       |tee $(BASE_DIR)/graphs/$(@).dot \
+       |dot $(BR2_GRAPH_DOT_OPTS) -T$(BR_GRAPH_OUT) -o $(BASE_DIR)/graphs/$(@).$(BR_GRAPH_OUT)
 
 else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)