package/vlc: configure.ac does not support --en/--disable-freerdp
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 17 May 2016 20:48:44 +0000 (22:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 9 Jun 2016 22:14:41 +0000 (00:14 +0200)
Vlc configure does not allow disabling the optional dependency to
freerdp:
http://git.videolan.org/?p=vlc/vlc-2.2.git;a=blob;f=configure.ac;h=e021546e284d7daefdb4d94f430eb0bc57722210;hb=HEAD#l1890

Vlc configure prints a warning that the option --disable-libfreerdp
is not used:

configure: WARNING: unrecognized options: --disable-gtk-doc,
 --disable-gtk-doc-html, --disable-doc, --disable-docs,
 --disable-documentation, --with-xmlto, --with-fop, --enable-ipv6,
 --disable-libfreerdp

This can be seen for example in autobuilder logs:
http://autobuild.buildroot.net/results/1a7/1a7893c13f6144e0ecd9f37f2f047c596ccedd35/build-end.log

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/vlc/vlc.mk

index 30887bd2729c2ae81fd6cd7303275354be7095de..4dc8dfe2f99c058143bdcd2d49aa7161da0cf983 100644 (file)
@@ -137,10 +137,7 @@ VLC_CONF_OPTS += --disable-flac
 endif
 
 ifeq ($(BR2_PACKAGE_FREERDP),y)
-VLC_CONF_OPTS += --enable-freerdp
 VLC_DEPENDENCIES += freerdp
-else
-VLC_CONF_OPTS += --disable-libfreerdp
 endif
 
 ifeq ($(BR2_PACKAGE_HAS_LIBGL),y)