busybox: don't disable static option
authorPatrick Ziegler <patrick.ziegler@fh-kl.de>
Sun, 14 Apr 2013 23:09:16 +0000 (23:09 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 17 Apr 2013 19:51:11 +0000 (21:51 +0200)
Don't change the busybox STATIC option if buildroots PREFER_STATIC_LIB option
is not set. Not to prefer static linking doesn't imply prefer dynamic linking
for all packages.

Signed-off-by: Patrick Ziegler <patrick.ziegler@fh-kl.de>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/busybox/busybox.mk

index 900896f700b30f4a3256154f211dbb23b7c71a54..985203c6e62aedaf3108f3acf19420a729e57bcf 100644 (file)
@@ -106,10 +106,6 @@ ifeq ($(BR2_PREFER_STATIC_LIB),y)
 define BUSYBOX_PREFER_STATIC
        $(call KCONFIG_ENABLE_OPT,CONFIG_STATIC,$(BUSYBOX_BUILD_CONFIG))
 endef
-else
-define BUSYBOX_PREFER_STATIC
-       $(call KCONFIG_DISABLE_OPT,CONFIG_STATIC,$(BUSYBOX_BUILD_CONFIG))
-endef
 endif
 
 # Disable usage of inetd if netkit-base package is selected