sigrok-cli: new package
authorBartosz Golaszewski <bgolaszewski@baylibre.com>
Thu, 29 Jan 2015 11:35:39 +0000 (12:35 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 1 Feb 2015 22:47:34 +0000 (23:47 +0100)
[Peter: needs host-pkgconf, simplify pre configure hook]
Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/sigrok-cli/Config.in [new file with mode: 0644]
package/sigrok-cli/sigrok-cli.mk [new file with mode: 0644]

index 1f37c7e4b79f8f69a43abfd2c8ba7c15717beb81..e7aa6d094954b4c1fb89e3cdf4994976833fdc74 100644 (file)
@@ -365,6 +365,7 @@ endif
        source "package/sdparm/Config.in"
        source "package/setserial/Config.in"
        source "package/sg3_utils/Config.in"
+       source "package/sigrok-cli/Config.in"
        source "package/sispmctl/Config.in"
        source "package/smartmontools/Config.in"
        source "package/smstools3/Config.in"
diff --git a/package/sigrok-cli/Config.in b/package/sigrok-cli/Config.in
new file mode 100644 (file)
index 0000000..e3e5420
--- /dev/null
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_SIGROK_CLI
+       bool "sigrok-cli"
+       select BR2_PACKAGE_LIBSERIALPORT
+       select BR2_PACKAGE_LIBSIGROK
+       # libsigrok->libglib2:
+       depends on BR2_USE_WCHAR
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_USE_MMU
+       help
+         Sigrok-cli is a command-line frontend for the sigrok
+         software suite.
+
+         http://sigrok.org/wiki/Sigrok-cli
+
+comment "sigrok-cli needs a toolchain w/ wchar, threads"
+       depends on BR2_USE_MMU
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/sigrok-cli/sigrok-cli.mk b/package/sigrok-cli/sigrok-cli.mk
new file mode 100644 (file)
index 0000000..6051d6d
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# sigrok-cli
+#
+################################################################################
+
+SIGROK_CLI_VERSION = 198487f611d8a7be4fa15017c22fa01a56551ca6
+# No https access on upstream git
+SIGROK_CLI_SITE = git://sigrok.org/sigrok-cli
+SIGROK_CLI_LICENSE = GPLv3+
+SIGROK_CLI_LICENSE_FILES = COPYING
+# Git checkout has no configure script
+SIGROK_CLI_AUTORECONF = YES
+SIGROK_CLI_DEPENDENCIES = host-pkgconf libsigrok
+SIGROK_CLI_CONF_OPTS = --with-libsigrokdecode=NO
+
+define SIGROK_CLI_ADD_MISSING
+       mkdir -p $(@D)/autostuff
+endef
+
+SIGROK_CLI_PRE_CONFIGURE_HOOKS += SIGROK_CLI_ADD_MISSING
+
+$(eval $(autotools-package))