package/Makefile.in: fix ABI name for EABIhf targets
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 23 Aug 2013 18:40:16 +0000 (20:40 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 27 Aug 2013 20:46:11 +0000 (22:46 +0200)
The current code to set ABI on ARM does the following:

ifeq ($(BR2_arm)$(BR2_armeb),y)
... set ABI without 'hf' suffix ...
else ifeq ($(BR2_ARM_EABIHF),y)
... set ABI with 'hf' suffix ...
endif

But since $(BR2_arm)$(BR2_armeb) will always be 'y' in the cases where
BR2_ARM_EABIHF is 'y', it means that the 'else' part of the condition
will never be used.

Fix this by appending 'hf' to the ABI variable when BR2_ARM_EABIHF is
selected.

[Peter: put EABIhf handling under arm/armeb conditional for consistency]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.in

index aed28d5a27e153e32561994cf905e45e40202475..91ae1b9bc8434fef76e54b533186dc984c4ae10f 100644 (file)
@@ -46,11 +46,9 @@ ABI=gnueabi
 else
 ABI=eabi
 endif
-else ifeq ($(BR2_ARM_EABIHF),y)
-ifeq ($(LIBC),uclibc)
-ABI=gnueabihf
-else
-ABI=eabihf
+
+ifeq ($(BR2_ARM_EABIHF),y)
+ABI:=$(ABI)hf
 endif
 endif