undo changes for wtmp and last log
authorDavid Anders <dave123@abcsinc.com>
Tue, 24 Jan 2006 15:53:15 +0000 (15:53 -0000)
committerDavid Anders <dave123@abcsinc.com>
Tue, 24 Jan 2006 15:53:15 +0000 (15:53 -0000)
package/dropbear/dropbear.mk

index 8d5159d86efdbdf0413007e804d87c334633e06e..5c46e005060d40995a5249cfa78079b8fe13654f 100644 (file)
@@ -42,8 +42,7 @@ $(DROPBEAR_DIR)/.configured: $(DROPBEAR_DIR)/.unpacked
                --mandir=/usr/man \
                --infodir=/usr/info \
                $(DISABLE_NLS) \
-               --disable-wtmp \
-               --disable-lastlog \
+               --with-shared \
        );
 ifeq ($(strip $(BR2_PACKAGE_DROPBEAR_URANDOM)),y)
        $(SED) 's,^#define DROPBEAR_RANDOM_DEV.*,#define DROPBEAR_RANDOM_DEV \"/dev/urandom\",' \
@@ -71,7 +70,6 @@ $(TARGET_DIR)/$(DROPBEAR_TARGET_BINARY): $(DROPBEAR_DIR)/$(DROPBEAR_BINARY)
        ln -snf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dbclient
        ln -snf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearkey
        ln -snf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearconvert
-       ln -snf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dbclient
        cp $(DROPBEAR_DIR)/S50dropbear $(TARGET_DIR)/etc/init.d/
        chmod a+x $(TARGET_DIR)/etc/init.d/S50dropbear