libshout: new package
authorJörg Krause <jkrause@posteo.de>
Wed, 15 Oct 2014 21:23:48 +0000 (23:23 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 17 Oct 2014 14:14:08 +0000 (16:14 +0200)
[Peter: fix Config.in indentation, license, needs host-pkgconf, optionally
 use libtheora and speex]
Signed-off-by: Jörg Krause <jkrause@posteo.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/libshout/Config.in [new file with mode: 0644]
package/libshout/libshout.mk [new file with mode: 0644]

index 93e148d3000239229928be1f43a710f4a98c2fcf..4c6685a89fd31b61784a5a36ac7cfadb26bc3499 100644 (file)
@@ -807,6 +807,7 @@ menu "Networking"
        source "package/librsync/Config.in"
        source "package/libsocketcan/Config.in"
        source "package/libshairplay/Config.in"
+       source "package/libshout/Config.in"
        source "package/libsoup/Config.in"
        source "package/libstrophe/Config.in"
        source "package/libtirpc/Config.in"
diff --git a/package/libshout/Config.in b/package/libshout/Config.in
new file mode 100644 (file)
index 0000000..9029342
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_LIBSHOUT
+       bool "libshout"
+       select BR2_PACKAGE_LIBOGG
+       select BR2_PACKAGE_LIBVORBIS
+       help
+         Libshout is a library for communicating with and sending data to an
+         icecast server.  It handles the socket connection, the timing of the
+         data, and prevents bad data from getting to the icecast server.
+
+         http://icecast.org/download/
diff --git a/package/libshout/libshout.mk b/package/libshout/libshout.mk
new file mode 100644 (file)
index 0000000..1166f58
--- /dev/null
@@ -0,0 +1,28 @@
+################################################################################
+#
+# libshout
+#
+################################################################################
+
+LIBSHOUT_VERSION = 2.3.1
+LIBSHOUT_SITE = http://downloads.xiph.org/releases/libshout
+LIBSHOUT_LICENSE = LGPLv2+
+LIBSHOUT_LICENSE_FILES = COPYING
+LIBSHOUT_INSTALL_STAGING = YES
+LIBSHOUT_DEPENDENCIES = host-pkgconf libogg libvorbis
+
+ifeq ($(BR2_PACKAGE_LIBTHEORA),y)
+LIBSHOUT_CONF_OPTS += --enable-theora
+LIBSHOUT_DEPENDENCIES += libtheora
+else
+LIBSHOUT_CONF_OPTS += --disable-theora
+endif
+
+ifeq ($(BR2_PACKAGE_SPEEX),y)
+LIBSHOUT_CONF_OPT += --enable-speex
+LIBSHOUT_DEPENDENCIES += speex
+else
+LIBSHOUT_CONF_OPTS += --disable-speex
+endif
+
+$(eval $(autotools-package))