check-package: enable for boot/
authorRicardo Martincoski <ricardo.martincoski@gmail.com>
Sun, 1 Apr 2018 05:08:17 +0000 (02:08 -0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 1 Apr 2018 06:49:18 +0000 (08:49 +0200)
This directory can benefit from this script to prevent common mistakes
when submitting patches.

In order to accomplish this:
Do not ignore anymore files from the boot/ directory.
Ignore boot/barebox/barebox.mk as it declares a package infra and not a
package itself.

Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
utils/check-package

index 8d10affabdc2cd9154699226ad3ba1ac559b6899..48ce9564432b20ee42d9a52698c020fc07972942 100755 (executable)
@@ -47,10 +47,12 @@ def parse_args():
 CONFIG_IN_FILENAME = re.compile("/Config\.\S*$")
 DO_CHECK_INTREE = re.compile("|".join([
     "arch/",
+    "boot/",
     "package/",
     "system/",
     ]))
 DO_NOT_CHECK_INTREE = re.compile("|".join([
+    "boot/barebox/barebox\.mk$",
     "package/doc-asciidoc\.mk$",
     "package/pkg-\S*\.mk$",
     ]))