pkg-infra: correct the source name for host-only packages
authorArnout Vandecappelle <arnout@mind.be>
Sun, 14 Oct 2012 05:17:34 +0000 (05:17 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 15 Oct 2012 08:21:33 +0000 (10:21 +0200)
Host-only package that don't define their <PKG>_SOURCE variable would
default to host-<pkg>-<version>.tar.gz.  It's more logical to remove
the host- prefix in this case.

This problem is most apparent with host-only packages downloaded from
version control, because they never define <PKG>_SOURCE.

Reported by Thomas Petazzoni and initial analysis by Luca Ceresoli.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tested-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pkg-generic.mk

index ffe7dfbc5f762ec7dff14e7da3d249a49cc25771..270da60c62dcadd338f0571b4dfd44f4ceb2d551 100644 (file)
@@ -231,7 +231,7 @@ ifndef $(2)_SOURCE
  ifdef $(3)_SOURCE
   $(2)_SOURCE = $($(3)_SOURCE)
  else
-  $(2)_SOURCE                  ?= $$($(2)_BASE_NAME).tar.gz
+  $(2)_SOURCE                  ?= $$($(2)_RAWNAME)-$$($(2)_VERSION).tar.gz
  endif
 endif